1
0
-1

Hello, I have a situation where an URouter is not working because of a licensing error. I have the DLM connected through a separate license server. Is there a way to configure my enviroment and solve this situation?


Regards

    CommentAdd your comment...

    2 answers

    1.  
      1
      0
      -1

      Hi Gianni, so when I switched the emergency license to my real license I get this error:


      Checkout of license feature USRVSVC failed, reason:
      The system id that was authorized for the requested application
      does not match.
      Borrowed :: The application that was requested is not licensed.
      7188@10.5.37.24 :: The system id that was authorized for
      the requested application does not match.
      7188@10.5.37.24 :: Under the current set of conditions,
      in the active license environment, grace is not authorized.
      compulock :: The application that was requested is not licensed.

      Fatal error: 8011 - License not available.
      Fatal error: 8011 - License not available.

      1. Gianni Sandigliano

        Hi Alejandro,

        the message is self explanatory: you are requesting to the license manager to use a feature called USRVSVC and this feature is not available in your license.

        USRVSVC is the Uniface Application Server which is the basis to execute:
        - Uniface Services on the server.
        - Uniface USP/DSP as Web Application Server.

        Are you sure your Uniface license certificate is enabling you to use Uniface Server(s)?

        You can find more info on Uniface license features here on uniface.info at this page and/or you can ask for more info to your Uniface contact person.

        Hope it helps.

        Gianni


      2. Alejandro Blanco

        As you can see in the image I have that feature in my license... And in my .asn used by the userver is the LICENSE_OPTIONS line too. I tested with a Windows APS and is working so I'm guessing that I need to configure something else with the userver...???


      3. Gianni Sandigliano

        Hi Alejandro,

        mmmhhhmmm...let's ask two questions before trying a diagnosis:

        1) I suppose your DLM is installed on 10.5.37.24. Right?

        2) Have you tried to configure and start USRVSVC on the same machine as DLM? If NO, let's give it a try.

        Gianni

      4. Alejandro Blanco

        1) Yes, in fact the DLM is installed in both servers, I have a others web application running locally on 10.5.37.24.

        2) Yes of course, I even installed an emergency license on the other server and is running fine.

      5. Gianni Sandigliano

        Hi Alejandro,

        your answers are confirming to me your issue is probably connected to the structure of your Uniface license: the USRVSVC feature in your license is "NodeLocked" type as can be seen in the screenshot.

        It means that feature could be used only in the server to which the license was associated.

        I suggest you to verify your needs with your Uniface sales reference.

        Gianni

      6. Alejandro Blanco

        Thanks Gianni you've been really helpful

      CommentAdd your comment...
    2.  
      1
      0
      -1

      Hi Alejandro,

      URouter AFAIK does NOT need for itself a license but it is usually starting UServer(s) which requires a license.
      The ASN file of your UServer(s) should include a line like:

      $LICENSE_OPTIONS {=} {LM_LICENSE_FILE=LocationList}

      where locationList, having DLM on another machine, should be in the format port@server.

      Hope it helps.

      Gianni

      1. Alejandro Blanco

        Thanks Gianni, alredy got the webapp working!!!

      CommentAdd your comment...