[SOLVED] Uniface 9.7.04 Final Patch compilation error

Author: maciokr@natfuel.com (RobM)

We've just done a fresh install of Uniface 9.7.04 and applied the last patch before the 9.7.05 release.  When compiling components whether from the dialog box or within the IDE/F I receive the following error:   Error on creation form/application file  1114 - ****** NO NEW COMPONENT CREATED *******   The folder exists and the logged in user has appropriate rights to the folder   Uniface help is not very helpful:

1114 ****** NO NEW FORM CREATED *******

Explanation

A serious error prevented compilation of the component. See previous messages to locate the problem. Correct the error and compile again.
 

3 Comments

  1. Have you already tried compiling the components from the command line with /pri=64? This should tell you where Unfiace tries to create/write the compiled component. Either the target location is not correct (i.e. directory does not exist) or the files in question already exist and are locked by another process. These are just two possible sources for the mentioned compile error. You also could use the Windows Sysinternals tool Process Monitor for trouble shooting the problem. This should give you even more details about what is causing the problem. Hope this helps. Kind regards, Daniel Iseli Uniface Support


    Author: diseli (daniel.iseli@uniface.com)
  2. Please disregard and mark this as solved or just remove if possible.  It turns out our network security team was "working on the server" while I was attempting the compilations.  All is good now.  My apologies.


    Author: RobM (maciokr@natfuel.com)
  3. Thanks for the info. And no worries. It's good to hear that you could resolve the problem.


    Author: diseli (daniel.iseli@uniface.com)