[SOLVED] Renamed UNIFACE.EXE application cannot be started error 0x000020c

Author: jroberson@canberra.com (Joanne Roberson)

Hello, I am at a customer site installing our application.  (I tried to create a call, but got stuck in an endless loop asking for a CAPTCHA).  I did send an email to customer support, but I had issues with that as well.  So I will post what I sent to customer support in the hopes that someone has seen this before? Operating system: Windows 2008 R2 SP1 Database:  Oracle 12.0.1 c, 64-bit Uniface version: 9.7.04 G408 As part of our installation we copy the UNIFACE.EXE to a folder and then rename it – in this case we call it HIS20_BATCH.EXE. When I tried to run this exe, I get an error that the application did not start correctly 0x000020c.  When I start UNIFACE.EXE and pass it a startup shell name it works fine.  Example:

DOS c:\his20\appl\his20_batch.exe /adm=<blah blah blah> /asn= <blah blah blah> “PARAMETERS” – I get the error

DOS c:\his20\uniface9\common\bin\uniface.exe /adm=<blah blah blah> /asn=<blah blah blah> HIS20_BATCH.APS “PARAMETERS” – it works I tried manually copying UNIFACE.EXE and renaming it (versus the installation doing it) and the error still occurs. I have checked the path to make sure there wouldn’t be any 32-bit DLLS getting loaded first, but then, that doesn’t make sense to me anyhow, since I can start the executable by passing I the startup shell name; it is just when it is copied and renamed that we are having the problem. The work-around is not really viable to the customer.

2 Comments

  1. Hello Joanne, The error code 0x000020c is not valid (the value should be 10 long and not 9). I've found 0xC000020C (STATUS_CONNECTION_DISCONNECTED), which apparently means: "The transport connection is now disconnected" (see here). From what I could find (so far) this error seems to indicate that there's a network problem. Not sure though why this should only happen with a renamed executable, but this looks more like a hardware error than a Uniface error. Have you already checked if the renamed uniface.exe is still a valid file? Any additional errors in the Windows Event Log? And maybe it's worth using the Microsoft Windows Sysinternals tool Process Monitor. Hopefully this will give you some additional info why the renamed uniface.exe cannot be loaded. Also, I don't really understand why specifying the start-up shell name is not a viable workaround. If this allows the customer to use the application then he should be happy (I guess). Hope this helps. Kind regards, Daniel


    Author: diseli (daniel.iseli@uniface.com)
  2. I finally found the solution: I added the renamed executable to the Windows Firewall "Allow an app through Windows Firewall".


    Author: Joanne Roberson (jroberson@canberra.com)