Uniface 9.3 and MS SQL Server compatibility level.

Author: gvandekrol@dejong.com (gvdkrol)

Uniface 9.3 is compatible with MS SQL Server 2012.  Can I use MS SQL Server 2017 and set compatibility level to 2012 for the database? Or do I have to install the actual MS SQL Server 2012? Thanks

3 Comments

  1. Uniface 9.7.05 supports MS SQL Server 2016 and 2017, so you should be good to go without setting compatibility levels.


    Author: Theo Neeskens (tneeskens@itblockz.nl)
  2. Uniface needs to talk to the database MIDDLEWARE. If (IF!) you can get that to be compatible, you are good to go. 9.3 is no longer supported by Uniface, so unfortunately you'll need to investigate yourself.


    Author: Theo Neeskens (tneeskens@itblockz.nl)
  3. Okay thanks for your answer. Uniface 9.7 is compatible with MS SQL Server 2016. Do you know if it would be supported if I get MS SQL Server 2017 and set the compatibility level to 2016 for the specific database accessed by Uniface?


    Author: gvdkrol (gvandekrol@dejong.com)