[SOLVED] Zip Error

Author: ablancouribe@compuamerica.com.ve (bioalexy)

Hi, Testing mi application I found some missing glyphs and errors -50 activating some forms and the error context show me this: ZIP error:(ZIPERR_LENGTH) on [E:\MyProject\Resources\MyUar.uar] '' - Data length mismatch What can I do to fix this?   Thanks

4 Comments

  1. We had the same problem. It was caused by some 'bad' glyphs. Or by editing the UAR with 7Zip.   We have send the UAR file to Uniface and they have checked which glyphs done errors.


    Author: Stijn Courtheyn (stijn.courtheyn@xperthis.be)
  2. Well, I think my problem is with some new glyphs I added to the library. What do you mean by bad glyphs? Could be a bad upload or simply the original file was corrupted?


    Author: bioalexy (ablancouribe@compuamerica.com.ve)
  3. We think there is a bug in the upload program of the glyphs. The glyphs works fine when we use the repository as datasource or we extract the UAR to a folder and use the folder as datasource. We have opened the images with snagit and saved them again as new png image and then imported it again. (before we have use Paint.Net)


    Author: Stijn Courtheyn (stijn.courtheyn@xperthis.be)
  4. This is a known problem in Uniface 9.7: Bug 31250 - Data length mismatch when reading objects from application UAR file resolution planned in service pack MG02 Symptoms: An application runs using UAR file. After getting a few objects from the UAR, the error: ZIP error:(ZIPERR_LENGTH) on [theapplication.uar] '' - Data length mismatch occurs, and glyphs and signatures are no longer found. This problem does not occur, when using a resource directory. Workaround Unpack the UAR and use this directory as resource (instead of the UAR file itself). For png images the following also worked: Change png images We used this online tool: http://www190.lunapic.com For example, just upload the png, then without changing anything, download the uploaded image (which will be just of a bit different size, but still 32x32). and NOT, not using paint.net with 9 bits depth. One can also still use the paint.net, but just change a bit of the image, then I believe it should work too. Recreate the glyphs with the new png images. The urm tool can be used to delete,add glyphs. Some urm examples: {uniface97installdir}\common\bin\urm.exe list myapp.uar:/gly/mygly*.gly >glylist.txt {uniface97installdir}\common\bin\urm.exe delete myapp.uar:/gly/mygly*.gly >>glydelete.txt merge 2 uar files {uniface97installdir}\common\bin\urm.exe merge glymod.uar myapp.uar >glymerge.txt single copy {uniface97installdir}\common\bin\urm.exe copy glymod.uar:/gly/mygly*.gly myapp.uar:/gly/mygly*.gly   [UPDATE] BUG#31250 has been fixed in the meantime in the Service Pack MG02 (release 9.7.03).


    Author: PBeugel (peter.beugel@uniface.com)