[SOLVED] Form panel does not appear

Author: fvenanciobr@gmail.com (fabricio)

Hi friends!!! I am trying Uniface 9.7.01 trial with default configuration (userver.asn, usys.ini). I created a library called "BIBLIOTECA". I created a panel called "BASICO". I created a form called "FRM0001" with library = "BIBLIOTECA" and panel = "BASICO", position = "TOP". I created a shortcut for my "SCC" start-up shell with this command:  C:\u97\common\bin\uniface.exe /asn=C:\u97\uniface\adm\userver.asn /adm=C:\u97\uniface\adm /ini=c:\u97\uniface\adm\usys.ini scc.aps But the form panel does not appear after the activate "FRM0001".exec(). I tryed /all, /pan and others, but the problem did not solved. Any idea? Hugs Fabricio Venancio Brazilian Uniface Developer Florianópolis/SC  Brazil

2 Comments

  1. Hi Fabrico, You need to add the library to your ASN file (with $variation). E.g.

    [SETTINGS] $variation=BIBLIOTECA

    More info about the search order for global objects can be found here. Hope this helps. Daniel


    Author: diseli (daniel.iseli@uniface.com)
  2. Thanks a lot Daniel


    Author: fabricio (fvenanciobr@gmail.com)