[SOLVED] error 0008 failed to activate startup-shell screen

Author: fvenanciobr@gmail.com (fabricio)

Hello folks!!!   I am trying to start a runtime application (Uniface 9.7.01) with this command:  C:\u97\common\bin\uniface.exe /asn=C:\u97\uniface\adm untime.asn /ini=c:\u97\uniface\adm\usys.ini SCC and in the IDF transcript show me this message: 0008 - failed to activate startup-shell screen I created a startup shell called "scc" with this "Application Execute" trigger: activate "FRM0001".exec() The file scc.aps were created in this path: C:\u97\Documents\Uniface 97 Development\project esources\aps The runtime.asn file has this configuration: [FILES] usys:*.xml usysuniface:misc\*.xml aps:*.aps C:\u97\Documents\Uniface 97 Development\project esources\aps\*.aps   Any idea? Thank´s a lot Fabricio Venancio Brazilian Uniface Developer

11 Comments

  1. Hi Fabricio, Your Uniface executable is not able to find the startup shell you defined on the command line, probably because a bad configuration into your asn file. You could try to: - add to your assignment file in the [settings] section: $putmess_logfile = FullPathNameToAWritableFile.log - start your application with /pri=127 on the command line. With these settings your application will notify you into the log file which file are opened on the file system and probably you will be able to fix your problem by yourself. Gianni


    Author: gianni (gianni.sandigliano@unifacesolutions.com)
  2. Hi Gianni   Thank you for help me... Follow this $ioprint = 127 results:   2015-11-01 08:41:20.38 - Uniface session started Loaded 'libdlm32' from C:\u97\common\bin\libdlm32.DLL, version: 9.0.2.220 Heartbeat process: SINGLE_THREAD, 1 Checkout UW10: -1 Feature UWALL expires in 30 days ULM Warning: the license for feature UWALL expires in 30 days Checkout UWALL: 1 ULM Warning: license for feature UWALL will expire within 30 days. Feature UCLIENT expires in 30 days ULM Warning: the license for feature UCLIENT expires in 30 days Checkout UCLIENT: 1 0008 - Failed to activate Start-up shell screen. Checkin UWALL: 1 Checkin UCLIENT: 1 2015-11-01 08:41:24.36 - Uniface session stopped


    Author: fabricio (fvenanciobr@gmail.com)
  3. Hi Fabricio, I don't see in your commandline a specification of /adm I use the following: "C:\Programme\Compuware\Uniface 9.6.04\common\bin\uniface.exe" "/adm=C:\Programme\Compuware\Uniface 9.6.04\uniface\adm" /ASN=..\ASN\TEST.ASN /INI=..\ASN\PROJEKT.INI ?


    Author: ulrich-merkel (ulrichmerkel@web.de)
  4. Hi Fabricio, Uniface 9.7 is by default configured to use Standardized Deployment (for details see the topic "What's New in Uniface 9.7.01" in the Uniface Library). So you need to make sure that the directory where the compiled output is located is added to the [RESOURCES] directory of your runtime.asn. E.g.

    [RESOURCES] C:/u97/Documents/Uniface 97 Development/project/resources

    And you can also have a look at (e.g.) the userver.asn in \uniface\adm. It is already set-up to use Standardized Deployment. If you, however, prefer to use Classic Deployment then have a look at the Uniface Library topic "Reconfigure Uniface for Classic Deployment". Hope this helps. Daniel


    Author: diseli (daniel.iseli@uniface.com)
  5. Thank´s a lot Daniel! I changed my command line including the userver.asn file.. The problem was solved...


    Author: fabricio (fvenanciobr@gmail.com)
  6. I get the error (error 0008 failed to activate startup-shell Screen) when i try to start debugging. At the code DEBUG the application stops with the error. There is nothing to find what "Startup-Shell" is failed to activate.


    Author: Lauterbach (norbert.lauterbach@infraserv.com)
  7. Lauterbach said I get the error (error 0008 failed to activate startup-shell Screen) when i try to start debugging. At the code DEBUG the application stops with the error. There is nothing to find what "Startup-Shell" is failed to activate.

    It sounds like the Debugger has a problem locating its own startup-shell. In Uniface 9.7 there should be a udbg.asn in both the \common\adm and and \uniface\adm directory with the following content:

    [SETTINGS] $language               USA $search_resources       resources_only [RESOURCES] usys:udbg.uar usys:usys.uar [DRIVER_SETTINGS] SEQ     U1.0 [PATHS] $DEF    SEQ:||

    This should be sufficient enough for the Debugger to locate the required components. It might be an idea to add $putmess_logfile and $ioprint to both udbg.asn files. Maybe you can isolate where the problem is? E.g.

    $ioprint = 64 $putmess_logfile = c:/temp/udbg%p.asn

    Hope this helps. Daniel


    Author: diseli (daniel.iseli@uniface.com)
  8. diseli said It sounds like the Debugger has a problem locating its own startup-shell. In Uniface 9.7 there should be a udbg.asn in both the \common\adm and and \uniface\adm directory with the following content:

    There is already an udbg.asn in \uniface\adm. Thus adding the /adm=.....\uniface\adm switch as Ulrich mentioned should do the trick. In that way, you avoid to modify files in your Uniface installation folders. If Uniface recommands to have a udbg.asn in \common\adm, Uniface should deliver that with the installation of Uniface 9.7 Wink


    Author: lejolyjl (jean-luc.lejoly@labsolution.lu)
  9. lejolyjl said
    diseli said It sounds like the Debugger has a problem locating its own startup-shell. In Uniface 9.7 there should be a udbg.asn in both the \common\adm and and \uniface\adm directory with the following content:
    There is already an udbg.asn in \uniface\adm. Thus adding the /adm=.....\uniface\adm switch as Ulrich mentioned should do the trick. In that way, you avoid to modify files in your Uniface installation folders. If Uniface recommands to have a udbg.asn in \common\adm, Uniface should deliver that with the installation of Uniface 9.7 Wink

    It seems that I've "tweaked" my environment a bit. EmbarassedThere's indeed only one udbg.asn and it's in \uniface\adm. And yes, pointing /adm to \uniface\adm should probably do the trick.


    Author: diseli (daniel.iseli@uniface.com)
  10. First of all Uniface searches the udbg.asn-File in the "working Directory". There we had a file with the following text (dated of 2006): [SETTINGS] $license_options        LM_LICENSE_FILE=7188@26appsys2 The Server 26appsys2 no longer lives for several years.   Uniface 9.6 works fine with this file. After deleting the file also Uniface 9.7 works fine.   Greets Norbert


    Author: Lauterbach (norbert.lauterbach@infraserv.com)
  11. Lauterbach said First of all Uniface searches the udbg.asn-File in the "working Directory". There we had a file with the following text (dated of 2006): [SETTINGS] $license_options        LM_LICENSE_FILE=7188@26appsys2 The Server 26appsys2 no longer lives for several years.   Uniface 9.6 works fine with this file. After deleting the file also Uniface 9.7 works fine.   Greets Norbert

    Thanks for the info. I, however, don't think that the problem with the "outdated" $license_options has caused the previously mentioned error 0008 (Failed to activate Start-up shell screen). Uniface 9.7 will use by default ($search_resources =) resources_only (this is set in the usys.asn). And since the udbg.asn file in the working directory probably did not include the required Debugger resources (usys:udbg.uar) the Debugger just could not locate its own start-up shell. Hope this helps. Daniel


    Author: diseli (daniel.iseli@uniface.com)