Help with Uniface Help is needed...

Author: eitan@amital.co.il (hareitan)

Hi.

The online Uniface Library help doesn't work for me on Windows 7. The left navigation panel is displayd and works ok, but the HTML help files to the right is not shown :-( Seems like a security problem, but I didn't find any working work-around... I've tried the registery fix that worked for my on XP, and tried to mark the server as a trusted site - nada.

Did anyone solve this problem and can help?

 

Thanks!

9 Comments

  1. Hello,

    Copy the CHM file to your local disk. That should do the trick.

    If not then check if the content is blocked by opening the file properties of the CHM file. If there's an Unblock button on the General tab of the file properties then press it.

    Hope this helps.

    Kind regards,
    Daniel

     


    Author: diseli (daniel.iseli@uniface.com)
  2. Thanks.

    I know coping to my local disk will allow my to open it, but I want it to be online from IDF, e.g. press F1 when selecting a command...

    I don;t have any "unblock" botton on the properties tab of the CHM file, and I gave a FULL CONTROL permission to all users - didn't help...


    Author: hareitan (eitan@amital.co.il)
  3. That's no problem. You just have to adjust the location of the ulibrary.chm file in the usys.asn. By default the following [FILES] assignment is defined:

    ulibrary.chm      usysuniface:doc\ulibrary.chm

    If you copy the CHM file to your local disk (e.g. c:\udoc\) then you have to change the file assignment as follows:

    ulibrary.chm      c:\udoc\ulibrary.chm

    And the reason why the content of CHM is not displayed when the file is located on a network drive is described in the following Microsoft Support Knowledge Base Article:

    The mentioned article also mentions some workarounds, but you have to keep in mind that these might introduce some security risks.

    And I've found another article on this topic that might be helpful:

    Please note that I have not tried any of the workarounds mentioned in the articles above. But I searched the Internet for Windows 7 related problems and other people indicated that the listed articles were helpful (for example: http://superuser.com/questions/75571/viewing-chm-files-across-the-network-in-windows-7)

    I hope the provided information is useful.

    Kind regards,
    Daniel


    Author: diseli (daniel.iseli@uniface.com)
  4. Thanks again for your help.

    Adjusting the ulibrary.chm to local disk helps. But - I don't want to copy this file to all local computers... and since the usys.asn is shared by all users, I can't do the adjustment unless I do copy the file to all computers...

    Working with the registery, as mentioned in Microsoft help, didn't work on my Windows 7 machine.


    Author: hareitan (eitan@amital.co.il)
  5. That's a pity to hear.

    But I did a quick test here (on VM running a Windows 7 Enterprise) and I've managed to get the Example 1 and 2 working from the previously mentioned Microsoft Support article:

    I used the following in a .cmd script (right-click, run as administrator) in order to get Example 1 working:

    REG ADD HKLM\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions /v MaxAllowedZone /t REG_DWORD /d 1 /f
    REG ADD HKLM\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions /v UrlAllowList /d "\\server\share;file://\\server\share"

    You obviously have to change the server and share name to whatever you would like to use. For example:

    • Uniface installed on the share \\machine123\uniface\ in the directory "\version 9.5\"
    • The ulibrary.chm is located here: \\machine123\uniface\version 9.5\uniface\doc\

    In this case the second line of the above mentioned .cmd script should look as follows:

    REG ADD HKLM\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions /v UrlAllowList /d "\\machine123\uniface;file://\\machine123\uniface"

    After I've executed the .cmd scriptas Administrator then I double-checked that the ulibrary.chm on the network share is not blocked (when accessed from the client).

    And I got Example 2 working when setting the value of MaxAllowedZone to 3 (and omitting the registry key UrlAllowLis). But setting MaxAllowedZone to 3 could be quite a security risk (since you're allowing that any .chm file is executed from the Internet including its content).

    I hope the provided information is helpful.

    Kind regards,
    Daniel


    Author: diseli (daniel.iseli@uniface.com)
  6. Does your VM machine run Windows 7 64bit or 32bit? We got the problem only on the 64bit version. Have tried the both regedit entries.

    Anyways, we did copy the CHM file to all local machines and it fixed it.

    Thank You!


    Author: hareitan (eitan@amital.co.il)
  7. Thanks for the info. I've used a 32-bit version Windows 7 - did not had the time yet to test this with 64-bit.

    But when I check the answers to "Viewing CHM Files Across The Network in Windows 7" here then you also have to add the described registry changes to the Wow6432Node registry node under HKEY_LOCAL_MACHINE\SOFTWARE\ (this is for 32-bit software running on 64-bit Windows). So if you add the following two lines to the previously mentioned .cmd script then that should (hopefully) do the trick:

    REG ADD HKLM\SOFTWARE\Wow6432Node\Microsoft\HTMLHelp\1.x\ItssRestrictions /v MaxAllowedZone /t REG_DWORD /d 1 /f
    REG ADD HKLM\SOFTWARE\Wow6432Node\Microsoft\HTMLHelp\1.x\ItssRestrictions /v UrlAllowList /d "\\machine123\uniface;file://\\machine123\uniface"

    I'll double-check this tomorrow on one of my 64-bit Windows 7 VM's.

    I hope the provided information is helpful.

    Kind regards,
    Daniel


    Author: diseli (daniel.iseli@uniface.com)
  8. Yep, adding the settings to the Wow6432Node registry node on 64-bit Windows 7 works like a charme. ;-)

    I hope the provided information is helpful.

    Kind regards,
    Daniel


    Author: diseli (daniel.iseli@uniface.com)
  9. Hi

    The 2 regedit values did the work :-) No need for the previous entries.

     

    Thanks again,

    Eitan


    Author: hareitan (eitan@amital.co.il)