Part #1 Install Uniface under Ubuntu 10.04 (Lucid Lynx)

Author: palgam0@hotmail.com (George Mockford)

To start the process of using Uniface under wine and Ubuntu I’ve split this into parts that will appear as weekly posts to Uniface.info. That way I can present the information in manageable and hopefully easily digestible parts.


Weekly Posts

  • Post #1 Get Uniface working Under Linux(Ubuntu) within ‘WINE’
  • Post #2 Address configuration settings
  • Post #3 Identify and if possible fix non functional areas
  • Post #4 Tips tricks. I expect (hope) by this point we might have some questions.

Beyond this point it depends on feedback. Areas that I’d like to explore are things like

  • * Wine 1.2 release (Sometime soon this year??? fingers crossed)
  • * Other versions of Linux (Ubuntu 10.10 (October), OpenSUSE, SUSE Enterprise, Red Hat etc)
  • * Explore ‘Native’ Uniface back-end with ‘WINE’ desktop (Hybrid approach)
  • * Explore restructuring install using standard Linux distro software/techniques (get-app, SUSE-YaST etc).
  •  

Software you need

  •  Ubuntu 10.4 codename “Lucid Lynx” April 29 2010
  • WINE 1.1.43 April 6 2010
  • Uniface  9.4.01 Including
    •       DLM 4.4.4
    •       Solid 4.5

Useful links and background reading:

 Wine home http://www.winehq.org

Wine FAQ  http://www.winehq.org/FAQ

Docs      http://www.winehq.org/documentation

Wiki      http://wiki.winehq.org

Bugzilla  http://bugs.winehq.org

 

Winetricks  http://wiki.winehq.org/winetricks

Codeweavers http://www.codeweavers.com/         Paid support for WINE

Bordeaux    http://bordeauxgroup.com/           Paid support for WINE

To keep this post small I’ve written the install and processes to deploy Uniface 9.4 under Ubuntu as a separate attachment. This is the promised Part #1 getting started and this should enable you to put the basic system in place and working.


So happy reading/building feedback is always appreciated.

-G

12 Comments

  1. Hi George,

    just went through your documentation. Excellent installation guide.

    We have a very cold and wet day herein  Germany
    and I am dead keen to follow your instructions this weekend.

    Will tell you more about the outcome when my installation is finished.

    Have a nice weekend and thanks for your initiative bringing uniface to the open linux world.

    Success, Uli


    Author: ulrich-merkel (ulrichmerkel@web.de)
  2. Thanks Uli,  if it's any consolation we have  high winds here and are under a Tornado watch so I'm not going anywhere either.

    One correction I noticed is that in the doc where you change the Uniface install config file it says to comment out the first three lines but in the image it shows the first four lines commented out. The image is correct the doc is wrong it should be comment out the first four lines. Sorry about that.

     


    Author: George Mockford (palgam0@hotmail.com)
  3. Hi George,

    thanks for your hint.

    Have a nice weekend, Uli


    Author: ulrich-merkel (ulrichmerkel@web.de)
  4. Hi George,

    over the weekend, I installed Ubuntu on my working notebook  so I can either boot XP or Ubuntu.


     

    My question:

    My Uniface License is fixed to this notebook and the DLM is running under XP.

    Is it possible to run DLM under ubuntu (and will it work as well as under XP)

    Or would it be better to install ubuntu on another PC so I can reach the DLM via LAN and port xxx.

     

    I want to avoid opening too many pits.

    Success, Uli


    Author: ulrich-merkel (ulrichmerkel@web.de)
  5. Hi Uli,  yes to DLM under Ubuntu. The 9.4 install will try to install DLM for you that's why I specified only solid as a pre-install and exactly the same under WINE in Ubuntu as it does under windows. Now that I think about this I'm glad that you brought this up as I forget sometimes that as a CPWR employee I have a lot more flexibility with respect  t o licensing.

    For the record my license is not node locked but is time stamped and will expire. It's valid for XP which BTW can be changed via 'wineconfig' so you do have a little flexability here to match wine to your existing license. If it's bound to a hostname and/or ethernet node then you would have to factor that in with how you installed Ubuntu. If the node name is the same it should work likewise the adaptor id but I've not tried this yet but added it to my "Must test list". If this doesn't work let me know what reply you get and I'll experiment some more.

    As for remote machine then this again should work provided that Ubuntu can access the license server. I'm challenged here as this project is outside  of my regular work so it's at home and my network is a little different than Compuwares and access to my PC via it's fully qualified hostname which I can't change for obvious reasons is an issue. Can't get DLM to work with IP addresses so in that respect I can't help unless I have a little more detail on your license type and network setup. If it becomes an issue we can talk offline and I'll be happy to work this out with you.

    In the meantime as a general rule if you can ping your license server from Ubuntu using the hostname (not ip) then an assignment setting for $LICENSE_OPTIONS = LM_LICENSE_FILE=7188@<your license server name> should work

    Hope this helps

    regards

    -G


    Author: George Mockford (palgam0@hotmail.com)
  6. Hi George,

    thanks for your fast reply.

    I have by now ubuntu and WINE running, hope to install SOLID today.

    On thursday, ve have a bank-holiday here in germany and i hope to complete your tutorial first part by then.

    Success, Uli


    Author: ulrich-merkel (ulrichmerkel@web.de)
  7. seems that you have to get a pgp key at first

    1) open a terminal (applications => Accessories => Terminal) and enter

    sudo add-apt-repository ppa:ubuntu-wine/ppa

    will take a little bit then you are informed the public key F9CB8DB0 is installed

    2) open the Software Center (applications => Ubuntu Software Center)

    open Edit => Software Sources ...

    the tab "Authentication" will show F9CB8DB0 2009-01-20 Launchpad PPA for Ubuntu WINE Team

    in tab "Other Software", use the "Add" button and add

    ppa:ubuntu-wine/ppa

    after leaving the "Software Sources ..." window, the installation will start.

     

    Sometimes it looks like you have to close and reopen the software Center, open "Software Sources" and come back for a sucessful installation.

    At last you get a new WINE menu in the Applications menu

    Success, Uli


    Author: ulrich-merkel (ulrichmerkel@web.de)
  8. Yeah I've experienced this also, it seems that occasionally an update  occurs successfully but you have to exit and re-enter to see the effects. I put this down to my lack of understanding of when to restart and when not to.

    This can be particularily annoying when installing and running a service like solid you will experience the wine "fixme:something" where "something" is a windows API or function call that is not yet implemented in wine. The "fixme" is simply a stub inviting developers to err  write code and fix it.   Sometimes this matters and others times it doesn't seem to have much effect but I have found out that sometimes a "reboot" appears to get things working.

    I'll try to point these out during the next post as I can appreciate that they can get a little annoying.

    thx Uli for the update.

     

    -G

     


    Author: George Mockford (palgam0@hotmail.com)
  9. Hi George,

    hopefully on thursday when I have completed your 1st part of tutorial,
    I will send you my annotated document with all my experiences.

    Success, Uli


    Author: ulrich-merkel (ulrichmerkel@web.de)
  10. Perthaps you can give me some hint on the following:

    C:\USYS9401\common\usys\usys.urr - Invalid Zip file
    ZIP error:(ZIPERR_DATA) on 'C:\USYS9401\common\usys\usys.urr' - Invalid data in zipfile structure
    C:\USYS9401\common\usys\usys.urr - Invalid Zip file
    ZIP error:(ZIPERR_DATA) on 'C:\USYS9401\common\usys\usys.urr' - Invalid data in zipfile structure
     
    got that while starting uniface for the first time.

     

    I tried the same steps you recommended in my windows environment w/o problems

    TIA, Uli


    Author: ulrich-merkel (ulrichmerkel@web.de)
  11. looked like the usys.dol and usys.urr I got from my 9.4.01 GA differed from the ones used in the VMware version.

    I put these and an annotated documentation in a dITo file to download.

    Success, Uli


    Author: ulrich-merkel (ulrichmerkel@web.de)
  12. Thanks Uli, good to see that you have a working version.  I'm still a little concerned and confused as what happened with the original install to "corrupt" the DOL and URR files? I've done this install with Ubuntu at least a dozen times and I will admit to a few issues but that was due to my experimentation on what works and what does not.

    If anyone tries the basic Ubuntu install and has similar experiences I'd appreciate any feedback so I can investigate further.

    In the meantime appreciate your Time and support Uli

    Success    -G


    Author: George Mockford (palgam0@hotmail.com)