Problem to call a webservice [U8.4.06]

Author: spanish_uniface@hotmail.es (uniface8)

Hi, i´m trying to call-out a webservice making in uniface but the application returns $status=-150

SOAPCE::handleRequest Connector:Connection failed or server refused connection (request might exceed MaxPostSize). HRESULT=0x800A151E - Client:An unanticipated error occurred during the processing of this request. HRESULT=0x800A151E - Client:Sending the Soap message failed or no recognizable response was received HRESULT=0x800A151E - Client:Unspecified client error. HRESULT=0x800A151E

I think i follow the correct steps:

First install tomcat and MSSOAP toolkit

1.- generate de service in uniface (testws)

2.-generate the wsdl file

3.- add this file to tomcat´s path

4.- recompile urr file

5.-generate the signature (testwsservice)

6.- generate the form that calls the webservice

7.- start tomcat

8.- test the form

But in the 8 step fails, returns -150

Any ideas ?

Regards,Rafa.

6 Comments

  1. Changing the address in wsdl file to test the webservice,

    <soap:address location="http://server:8080/uniface/services/ws.wsdl"/>

    uniface returns:

    SOAPCE::handleRequest {USERVER:doSoapRequest:URBnewStatelessReq}Activation error: (-50, component name not found)

    but the component exist.

    Regards,Rafa.


    Author: uniface8 (spanish_uniface@hotmail.es)
  2. The location should point to the actual webservice, and not to the wsdl. The location must end with name of the web service (the uniface service you created the wsdl for) to call.

    The error you give in the initial message does not sound familiar to me.


    Author: sjaak (sjaak.van.schie@uniface.com)
  3. I tried that too, <soap:address location="http://localhost:8080/uniface/services/ws"/> and calling to the operation <soap:address location="http://localhost:8080/uniface/services/ws.operation"/> but the returns its the same. status=-50

    I´m using MSSoaptoolkit 3.0 and for test the webservice soapUI 3.0.1.

    I tried to follow the example of the oficial documentaton too, i created the calcmoneypayback webservice, but the response its the same status, -50


    Author: uniface8 (spanish_uniface@hotmail.es)
  4. I do not follow your steps exactly. The location that I expect should be .../services/testws since testws is the name of the Uniface service that you wrote (and not generated I expect) in step 1.

    The generated wsdl in step 2 holds a placeholder @@UnifaceLocationPlaceholder@@ that will be replaced on runtime in the SRDServlet.
    This generated wsdl can not be imported directly, since then the service location is unknown.

    You can import the wsdl using tomcat after copying it to the wsdl directory inside you uniface webapp underneigth WEB-INF.

    The wsdl to use is on http://server:8080/uniface/services/testws?wsdl . So step 3b should be start tomcat.

    Also the testwsservice should be compiled and placed in the urr file. A -50 may be given when the server can not find the signature. This can be urr file related. The urr file can be locked by the server so that idf can not update it.
    (You can check wether activate testws directly works.)

    The URL location of the wsdl file is also located is the properties of the Uniface SOAP signature (testwsservice). Maybe this is invalid.

    I do not think I can help you further on this.

    Sjaak


    Author: sjaak (sjaak.van.schie@uniface.com)
  5. Thank you, i´ll review all the steps to find the error.

    Regards,Rafa.


    Author: uniface8 (spanish_uniface@hotmail.es)
  6. Hello again, i tried to call a webservice generates by java and there is no problem:

    1.- Import  wsdl file using /Sti /mwr=ws http://server/path/service.wsdl

    2.- Compile the signature
     
    3.- Update urr
     
    4.- Test, an it´s ok.

    But when i create the webservice with uniface it doesn´t work, so i think that it´s a configuration problem.

     


    Author: uniface8 (spanish_uniface@hotmail.es)