[SOLVED] $TIMEOUT in RDP sessions

Author: gianni.sandigliano@unifacesolutions.com (gianni)

Hi Unifacers, I am facing with a Uniface application not activating ASYNC_INTERRUPT when $TIMEOUT is defined into ASN file to silently close the Uapplication after N idle minutes; this application is installed customer wide and it is used from SAME shared disk area in 2 different modes: 1) from standard Microsoft Windows workstations => $timeout is working as expected. 2) from Microsoft TerminalServer 2012 server for remote users => $timeout is NOT working. I've searched into Uniface Library and googled around without success... It should be noted an RDP session could left open/connected on the server but NOT in current use from end user. Should Uniface $timeout in an RDP session (really working or just open/connected and left there from end user) on a Microsoft TerminalServer server work as in a standard Windows workstation session? If YES, are there any pre-requisites (settings) to be applied at OS level on the TS server to have it working? If NO, could someone explain me why? Thanks in advance for any hint / suggestion / answer. Gianni

1 Comment

  1. I'm answering myself... :-) :-) :-) $TIMEOUT works correctly in all conditions: - Windows workstation from console - Windows workstation via RDP for Administration - Windows server from console - Windows server via RDP, user connected and using front-end - Windows server via RDP, user disconnected from front-end leaving remote session opened The issue found was probably caused from an updated startupshell being recompiled but being cached from RDP server. SOLVED! Gianni


    Author: gianni (gianni.sandigliano@unifacesolutions.com)