[SOLVED] U97 long time to open

Author: marco.aquino@dedalus.eu (Marco)

Hi, we migrated our customer from U9401R126 to U9703G308 and now he takes long time to open application. With U94 the application opens in few seconds, with U97 it takes around one minute. We migrated the repository and build a new URR and DOL from idf with /urr and /dol command line switch. We tried to use DOL and URR in local folder, but no improvement. We tried to redirect DOL and URR via asn to fake files and in this case the application is opened and closed in a few seconds, so I think that the problem is on DOL and URR. After a while we realized that the problem was related to the antivirus (kaspersky) when uniface application load DOL and URR files, only without antivirus the application starts like U94. These files are 10Mb and 6Mb respectively with thousand and thousand of files. The files are in network location like runtime itself. The application link is like this: \ etwork\share\folder untime\bin\uniface.exe /asn=\ etwork\share\folder\asn\file.asn /ini=\ etwork\share\folder\ini\file.ini STARTUP_SHELL and the startup folder is \ etwork\share\folder\project Why U94 and U97 have a different behavior than the antivirus? Is a known problem? Is there some suggestion about the settings to use (asn, ini, compiler, etc) to return at U94 load time (without disable the antivirus)? Enviroment: Platform: WIN7 Uniface: U97G308 DBRMS: Oracle 11g   Thanks Marco

10 Comments

  1. Marco, I think you have to put the Uniface dir or files in Kaspersky's exclusions


    Author: TheAleph (mail@gandg.it)
  2. We had some complaints from customers too with U9703G30X, now upgraded to U9703G317 and everything is fine again.   Also, try to work with UAR's. And yes, since Uniface 9.6 (guess) a dol is a zip file and recognized as such by the antivirus. We had to rework our application so that DOL and URR were no longer on a network share, since it is accessed constantly, and virus-scanned EVERY TIME. We have now moved on to UARs that are cached locally in a temp dir, and scanned (and hashed) by the antivirus only once. An antivirus exclusion could also work, but in our experience that doesn't always work very well on network shares.   Back in the days when we switched to Uniface 9.6, we also noticed a big difference in performance between DOLs and URRs hosted on Win2003 server shares and Win2008+ shares. The 2003 version just couldn't cope with the amount of reads on the DOL-file.   There's also a setting that makes Uniface read the complete DOL in memory (MEMORY_ZIP=ALL), that also helped a bit. The best solution by far was to include a version number in the DOL filename, download it locally in the temp dir and rewrite the asn everytime with the correct local DOL and URR filenames. Hope this helps Wink


    Author: wimmme (wim.vaneupen@xperthis.be)
  3. Hi, after analyzing with customer's network administrator, the exclusion of network folder doesn't do effect. The customer's network administrator saw that the long time is take by antivirus when it execute the functionality “scan Embedded OLE objects”. This antivirus functionality was active with U94 also. Does anyone know if the U97 use this functionality (or relative) to read DOL and URR differently from U94?   Marco


    Author: Marco (marco.aquino@dedalus.eu)
  4. Hi Marco, In order to improve performance the central directory of ZIP files is now mapped into memory. This change was introduced with version 9.6.01 and also with the patch R128 for version 9.4.01. The original issue was recognized as BUG#29726 and as solution the $MEMORY ZIP setting was introduced. If I recall it correctly then on Windows the ZIP files (including UAR, DOL, and URR files) are using the Windows swap file functionality. I'm not sure why this should give a "problem" with the Kaspersky "scan Embedded OLE objects" functionality. Have you already tried to exclude the affected DOL and URR files in Kaspersky from scanning? I guess this should resolve the performance problem. You could also try to disable the memory mapping of the ZIP files by using the setting $MEMORY ZIP=Off. This should (in theory) restore the version 9.4 behavior. But to me this looks like a problem with Kaspersky. We are using a different antivirus software here and we never encountered anything similar. And I'm also not aware that other customers have (so far) reported something comparable. Beats me. Hope this helps. Daniel


    Author: diseli (daniel.iseli@uniface.com)
  5. wimmme said ...since Uniface 9.6 (guess) a dol is a zip file...  

    Actually it's already since 9.3 (2009), please see this link.


    Author: Arjen van Vliet (arjen.van.vliet@uniface.com)
  6. If you're interested in standard deployment (formerly known as easy deployment), please see part 3 and part 4 of the Lecture on Deployment. And the presentation is on Slideshare.


    Author: Arjen van Vliet (arjen.van.vliet@uniface.com)
  7. diseli said Have you already tried to exclude the affected DOL and URR files in Kaspersky from scanning?

    We tried to add the main folder without success. Then we tried to insert uniface.exe into trusted applications. In this case the load time is back to normal.  

    You could also try to disable the memory mapping of the ZIP files by using the setting $MEMORY ZIP=Off. This should (in theory) restore the version 9.4 behavior.

    We tried the $MEMORY settings into asn and this option works, the load time is back to normal.   Thanks to all Marco


    Author: Marco (marco.aquino@dedalus.eu)
  8. Thanks for your feedback, Marco. That's good to know. Just out of interest: did you test both "fixes" separately or together? E.g. did you test $MEMORY ZIP=Off without adding uniface.exe to the trusted applications and $MEMORY ZIP=On (default value) plus adding uniface.exe to the trusted applications? Or are you using $MEMORY ZIP=Off in combination with uniface.exe as trusted application? Thanks, Daniel


    Author: diseli (daniel.iseli@uniface.com)
  9. diseli said Thanks for your feedback, Marco. That's good to know. Just out of interest: did you test both "fixes" separately or together? E.g. did you test $MEMORY ZIP=Off without adding uniface.exe to the trusted applications and $MEMORY ZIP=On (default value) plus adding uniface.exe to the trusted applications? Or are you using $MEMORY ZIP=Off in combination with uniface.exe as trusted application? Thanks, Daniel  

    Hi Daniel, the test on trusted application was done by customer's system administrator independently. Today I asked to customer's system administrator if the domain policy to insert uniface.exe into trusted application was launched before or after my test on asn. The answer is been before. So I don't know if only $MEMORY setting solve the problem. Now at the customer the $MEMORY setting isn't applied. So the time is back to normal only with uniface.exe into trusted application.   Marco


    Author: Marco (marco.aquino@dedalus.eu)
  10. Marco said Hi Daniel, the test on trusted application was done by customer's system administrator independently. Today I asked to customer's system administrator if the domain policy to insert uniface.exe into trusted application was launched before or after my test on asn. The answer is been before. So I don't know if only $MEMORY setting solve the problem. Now at the customer the $MEMORY setting isn't applied. So the time is back to normal only with uniface.exe into trusted application.   Marco  

    Hi Marco, Thanks for the info. This is quite useful to know. I, however, think that $MEMORY ZIP=Off should also solve the problem, since this will restore the behavior prior to the bug fix 29726. I would not know why Kaspersky (or Windows) would treat Uniface 9.4.01 + R126 as a "more trustful" application than version 9.7(.03 + G308). It should not make a difference. But you never know. Daniel


    Author: diseli (daniel.iseli@uniface.com)