[SOLVED] Field list in the Define Key window

Author: ablancouribe@compuamerica.com.ve (bioalexy)

Hi, I´m currently using Uniface 9.7.02 and I realized something when I was creating an index on an entity, the list of fields don´t show all the fields of the entity. I tested this on 9.7.01 and is fine so most be some bug on the new version.   Regards

2 Comments

  1. Hi, The described problem already has been recognized as BUG#31276 and it is currently being investigated by the lab. You, however, can avoid the issue by adding the setting $GRID_READALL_ON_STORECOMPLETE to the ASN (section [SETTINGS]) and set it to true:

    [SETTINGS] $GRID_READALL_ON_STORECOMPLETE = True Hope this helps. Regards, Daniel Iseli Uniface Technical Support


    Author: diseli (daniel.iseli@uniface.com)
  2. The BUG#31276 has been fixed in the meantime with the patch G304 (and higher). This means that the above described (not all fields are shown in the Define Key window) should also not occur anymore. Hope this helps. Regards, Daniel Iseli Uniface Technical Support


    Author: diseli (daniel.iseli@uniface.com)