sql/data error on oracle

Author: eitan@amital.co.il (hareitan)

I've just tried the new sql/data on oracle 10.2.0.3.0 and Uniface 9.6.05.02, and got DB error: ORACLE Driver Error [-6]: Unknown driver request.... sql/print works fine. Any ideas?   Thanks Eitan

5 Comments

  1. some more details, such as the proc, and the message frame would help a lot. 


    Author: Adrian Gosbell (adrian.gosbell@synapse-i.jp)
  2. For most platforms Uniface 9.6 supports Oracle 11R2 and higher: See Product Availability Matrix. Oracle 10R2 had also Oracle issues that affect Uniface: If you must use Ora10R at least Oracle 10.2.08 on client and server  is advisable.


    Author: PBeugel (peter.beugel@uniface.com)
  3. Adrian Gosbell said some more details, such as the proc, and the message frame would help a lot. 

    If(SQL_TEXT!="")    SQL/data SQL_TEXT, "DEF"    SQL_RESULT = $Result EndIf ;;;SQL_TEXT is: "select fld_a, fld_b from table where fld_a='123'" ;;;SQL_RESULT after proc is null ;;;$ProcError = -3, $ProcErrorContext is: "ERROR=-3·; MNEM=·; DESCRIPTION=I/O error·; COMPONENT=ZZZ_EITAN·; PROCNAME=328\DTLF·; TRIGGER=DTLF·; LINE=2" ;;;message frame shows: I/O function: Q, mode: 7, on driver: ORA ORACLE Driver Error [-6]: Unknown driver request. ORACLE Driver Error [-6]: Unknown driver request.   Thank you


    Author: hareitan (eitan@amital.co.il)
  4. Thanks for the info. Could you please also tell us which Oracle driver you are using (see section [DRIVER_SETTINGS] in your ASN)? Is it ORA U6.3 or maybe even U6.2? The driver error ("ORACLE Driver Error [-6]: Unknown driver request.") seems to suggest that the Oracle driver that is used is not from Uniface version 9.6.05, but from a release that does not support the sql/data statement (yet); i.e. <= version 9.6.04.


    Author: diseli (daniel.iseli@uniface.com)
  5. diseli said Thanks for the info. Could you please also tell us which Oracle driver you are using (see section [DRIVER_SETTINGS] in your ASN)? Is it ORA U6.3 or maybe even U6.2? The driver error ("ORACLE Driver Error [-6]: Unknown driver request.") seems to suggest that the Oracle driver that is used is not from Uniface version 9.6.05, but from a release that does not support the sql/data statement (yet); i.e. <= version 9.6.04.

    Thanks for your answer. We indeed use U6.2. I don't know why... Will Check.   Thanks again!


    Author: hareitan (eitan@amital.co.il)