[SOLVED] Entity using Grid widget not displayed as a grid

Author: dominique.roumegous@sabenatechnics.com (Dominique Roumegous)

Hi, I'm using 9.4.01. I have two IDF databases (for two different applications) used with the same installation of Uniface IDF on my computer (two INI and two ASN). In one IDF database if I define an entity to use the grid widget it is displayd as a grid at runtime, in the other IDF it is not displayed as a grid but uses the "classic" display. I try to switch the INI files but the IDF that don't want to display grids is still the same. I checked that the grid widget is defined in both INI files. Any idea ? Thanks for the help. Best regards, Dominique R.

4 Comments

  1. Hi Dominique, This issue sounds vaguely familiar. Could you please check in the environment that has the problem if there's an outdated Meta Dictionary (e.g. the repository models DICT) present (i.e. from a version older than Uniface 9). If that's the case then please import the Meta Dictionary that belongs to Uniface 9.4. You can find an export of the Meta Dictionary (umeta.xml) in usysuniface:misc (<Uniface 9.4 installation dictionary>\uniface\misc). Or just run the following IDF command line:

    • idf.exe /ins meta

    After importing the Meta Dictionary perform an Analyze Model, delete any existing udesc.urr file, and then recompile everything. After you've done this the Grid widget will (hopefully) be displayed again correctly at runtime. And if not then we'll need to look for other problems. Hope this helps. Best regards, Daniel


    Author: diseli (daniel.iseli@uniface.com)
  2. Hi Dominique A few hints: 1. Create a testform with only one simple, not elsewhere used enitity. So you are sute, that there is no (hidden) inheritance of attributes 2. Rename all INI files (including comm\adm and uniface\adm) and begin from the scratch be renming on entity by the other. Uniface will "tell" you, which are neseccary and which not 3. "Manipulate" the WIDGET section by inserting a wrong assignment So you will see, if Uniface really uses this section. 4. Uses different fonts in GRID-widget definition (in INI). Say on time TINYxyz the other HUGExyz So you can check if Uniface uses this widget. (Colors are also possible) 5. Check, if there is more then one definition in INI files Uniface only uses the first one(?) ... Ingo


    Author: istiller (i2stiller@gmx.de)
  3. Hi diseli, You were right, my environnment was from Uniface 7 migrated to 9. I reimported the Metadictinonary and the grid displayed ! Thanks a lot. Problem solved.   Thanks too istiller for your hints.


    Author: Dominique Roumegous (dominique.roumegous@sabenatechnics.com)
  4. Hi Dominique, Thanks for your reply and you are welcome. It's good to hear that you could resolve the problem. Please note that since Uniface 9.6.06 (or more specifically version 9.6.05 + patch X505) the Migrate Repository Utility form will recognize if an export file is imported that contains the meta dictionary of version 8 (or older). If that's the case then the Uniface 9 meta dictionary will be imported by default in phase 7 of the migration process. If, however, an export file is imported from the command line then it's still necessary to either import the meta dictionary manually (using e.g. the command line switch /ins meta) or run the Migrate Repository Utility manually. Hope this helps. Best regards, Daniel


    Author: diseli (daniel.iseli@uniface.com)