[SOLVED] $signatureproperties problem

Author: alex.meyers@cevi.be (ceviame)

situation we imported a WSDL, endpoint is ServerA, activate works fine we have to deploy to several customer sites with local webservice, so we make the location dynamical thru the use of $signatureproperties (svc=xxx) at the customer site, the value is ServerX, and we get an activate error -155  MESSAGE=WSDL reader error DETAIL=Instance::Instance WSDLException: faultCode ACCESS_ERROR, An exception occurred! Type:NetAccessorException, Message:The host/address 'ServerA' could not be resolved" what fooled us was that we tested the working of $signatureproperties inhouse with a ServerB and we got the response from this server (verifiable thru content) but this was in an environment were ServerA was also available the Help file says

The dynamic properties you set get merged with the properties defined in the assignment file (in the [SERVICES_EXEC] section and the USYS$SOP_PARAMS setting).This means that if a property is not set with $signatureproperties, the value as set in the assignment file is used. Thus, if you want the freedom to add and remove properties, do not define them in the assignment file.

We have nothing in the [SERVICES_EXEC] section and the USYS$SOP_PARAMS setting It looks to me that before using the value of $signatureproperties Uniface still first verifies the WSDL from the original site (the one that came along with the WSDL import) which will fail at a customer site by changing the value thru the signature editor and compiling/distributing we can get the webservice to work at 1 customersite (quick fix), but we have to go thru this for each customer   any comments or am i missing something ? Alex

3 Comments

  1. Hello Alex, $signatureproperties("myService") = "wsdl=.....;svc=....." could possibly help. Wolfgang


    Author: gypsilon (wva@gypsilon.de)
  2. Hello Alex, Wolfgang is right. You need to change both the WSDL and the SVC option. Please note that the WSDL (SOAP connector) option specifies the location of the WSDL file. In case the WSDL does not change you also could use a local WSDL file instead of loading it from a URL (accessing a local file is usually quicker). And the SVC option will override the endpoint URL of the web service that is specified in the WSDL. See also: Overriding the Location of Web Service and WSDL File in the Uniface Library. Hope this helps. Daniel


    Author: diseli (daniel.iseli@uniface.com)
  3. gypsilon said Hello Alex, $signatureproperties("myService") = "wsdl=.....;svc=....." could possibly help. Wolfgang

    Hi Wolfgang, the wsdl= did the trick we found the $signatureproperties documentation in Uniface Library a bit confusing but problem solved thanks Alex


    Author: ceviame (alex.meyers@cevi.be)