[SOLVED] Communication Uniface - Linux call .so (dll) in C 3GL function

Author: anne_vw@telenet.be (anne_vw)

Hi,   has anybody experience with calling a C-dll via uniface on Linux?

value in   /local/opt/ufr96/common/adm/urouter.asn

[SETTINGS] $putmess_logfile = /local/opt/ufr96/common/log/urouter%p.log $default_net = TCP:+13001||| [SERVERS] ; ========================================================================= ; Uniface servers ; ========================================================================= default = /local/opt/ufr96/common/bin/userver -maxidle=3m ; For Uniface WebApplication Server wasv = /local/opt/ufr96/common/bin/userver -dir=/local/opt/ufr96/common/project -adm=/local/opt/ufr96/uniface/adm -asn=wasv.asn Value  /local/opt/ufr96/uniface/adm/userver.adm ;================================================================================ [USER_3GL] ;================================================================================ /local/opt/ufr96/common/dll/helpureg.so    Value  /local/progs/test/ufr96/adm/tzisbat.asn  ;================================================================================ [USER_3GL] ;================================================================================ /local/opt/ufr96/common/dll/helpureg.so We keep on getting the error message that the signaure is not found Cry The application has tried to dynamically activate this 3GL function but could not find it. *** Check if you have an entry for this function in the [USER_3GL] section of your assignment file. Somebody out there to help us out? Best regards Anne

1 Comment

  1. Just as an FYI for the other forum users: This question also has been forward to Uniface Support: "Various issues were found getting 3GL call-out to work on Linux, and after that to call the same 3GL function from Windows. Confirmed that it all works now."


    Author: diseli (daniel.iseli@uniface.com)