Problem to see repository [U9.4 R107]

Author: spanish_uniface@hotmail.es (uniface8)

Hi all, we install the last patch of U9.4 (R107) and entities and code in local proc modules dissapear in some forms!!!!
We try to open the same forms without the last patch installed and we see it ok.
Someone have an answer?

Regards,Rafa.

 

 

13 Comments

  1. 107 already available? How many bugs are solved, any how many appeared? ;-)

    Just a guess:

    A similar behaviour in prior versions (before 107):

    The trigger looks like "empty", but in fact is not empty. Scroll up within the trigger, and the code will appear... I've got this in some situations, not always.

    Greetings, W.


    Author: gypsilon (wva@gypsilon.de)
  2. Thank you Wolfgang, but this time the trick don´t work.
    We think that it´s a problem with a DLL library.

    Regards,Rafa.


    Author: uniface8 (spanish_uniface@hotmail.es)
  3. I've now got a similar effect:

    (Patchlevel 106 and before): In seldom times entering a formname in the Quick navigation:
    It looks like, that the from is not loaded, and all remains empty.

    A "refresh" brings the trigger back, but not the structure and the canvas (only the splitbars on the canvas).

    The circumstances not yet analysed in which situations, and not yet reported to cpw.
    Then I do a "form open..." instead (via menu). This works always (before 107).
    The "Quick navigation" seemes to be an 80 % solution.

    Since I observed this only in the quick-navigation, I think this is a bug in the mechnism of the quick navigation, which works in general a bit buggy.

    Wolfgang


    Author: gypsilon (wva@gypsilon.de)
  4. Got similar things on 8.4.03 happen WITH QUICK NAV when component is based on a template

     Success, Uli


    Author: ulrich-merkel (ulrichmerkel@web.de)
  5. Hi Wolfgang

    We had exactly the same problem with the quick nav. We've reported the problem to Compuware, but the labs response was : no work on this kind of bug.

    I don't know why, but it seems the labs don't want to spend time on bugs not clearely identified with a test set :-/

    Kind regards,
    Richard


    Author: richard.gill (richard.gill@agfa.com)
  6. Hi Richard,

    I would understand that cpw does not fix these kind of bugs, if the promised user-driven 9.5. will have better ways or
    mechanism of navigation through components... (and the current solution will get obsolete).
    But who knows?

    On the other hand: A feature, working only 80 % correct is useless(!)
    Even the history in the Quick-nav does not work as expected. I detected this bug the first time using 9.4...
    It can't be so difficult to reproduce it, since at least 4 users are now talking of the same problem.

    What's the workaround of the call? Don't use Quick-nav... Why introduced??

    Wolfgang
     


    Author: gypsilon (wva@gypsilon.de)
  7. The workaround ? No time spent means implicitly no workaround, which means : use it at your own risk, knowning the problem.

    Here we decided to stop using the quick nav, because, it's really annoying to switch a component, see it's empty, then use File/Open, or Ctrl+O (not talking about the real plus of quick nav : switch to component of different type, from form to service for example). Sometimes, bad habits come back and I use the quick nav by automatism. As I use it rarely (because I tend to avoid its usage), I rarely have the problem.

    I can't tell you what to do. I just wanted to point out the problem is known in the labs, but they won't do anything (they should at least remove it, you're right).

    Kind regards,
    Richard


    Author: richard.gill (richard.gill@agfa.com)
  8. Hi, just from my "dITo" part of the brain

    In "foreign" applications (working as an external), I prefer "Global Action" as my edit launcher:

    Just Enter component name (no need to remember what kind of service it is) and press "EDIT".

    Success, Uli

    P.S.It's not so elegant if you need to transfer code from one component into another.
    But we have a dITo task for editing in a broader context which makes these kind of code-typing a snap.


    Author: ulrich-merkel (ulrichmerkel@web.de)
  9. Exactly my minds. Possibly cpw can comment the situation ?

    @Rafa:

    Is this what you detected, or got it even more worse with R107?

    Wolfgang


    Author: gypsilon (wva@gypsilon.de)
  10. It´s worse, the entities don´t appears in layout editor, but exist in the repository database and the same thing with the code in local proc modules.
    But, good news for us, the Lab tell me a solution, we have to add the parameter "field aligment:4" and it works. We are using a DB2 database.

    Rafa.


    Author: uniface8 (spanish_uniface@hotmail.es)
  11. hi Rafa

    What's the field alignment parameter about ? It's a DB2 driver option ? If so, which signification ? We use Oracle, maybe a similar workaround could be envisaged :)

    PS : Does it work at all ?

    Kind regards,
    Richard


    Author: richard.gill (richard.gill@agfa.com)
  12. Hi Richard,
    yes, it´s a DB2 driver option, it´s not documentated, you can see all the driver options in the log file, documentated or not, if you write an inexisting option, e.g:
    USYS$DB2_PARAMS = aaa: 500
    Then the log file have a line like:
    Unknown token "aaa" found. Expected: oc, logon timeout, logtime, open statements, os,....

    I don´t know the option for oracle, this parameter solves our issue (the disappear of code and entities) i don´t know if it´ll solve the quick navigation issue too.

    PD:By now, it works.

    Regards, Rafa.

     


    Author: uniface8 (spanish_uniface@hotmail.es)
  13. Hello Richard and Wolfgang,

    we have the same experience in here with quicknav (currently Uniface 9.3). This problem happens quite often and we can see it from the time we migrated to Uniface 9. We also reported this to CPWR but they just closed our call with no solution. :( They are aware of this problem, but since we can't reproduce it 100%, they refused to fix it. So we stopped using this featuer, since it does not work.

    The similar problem is with damaged code - I reported it to support and reported it here with screen-shot, but with the same result - no solution.

    Just my 2 cents ;-)
    Zdenek


    Author: sochaz (zdenek.socha@fullsys.cz)