Debugger: "Watches" "Locals" not visible

Author: juerg.fross@teamspirit.ch (jfro)

Hello

I am using Uniface 9.4.01 on Windows 7.

Until yesterday I had in using DEBUGGER a window splitted in 3 parts:

  • Component (top)
  • Watches (left down)
  • Locals (right down)

Maybe I did some manipulation - unfortunately I don't know what.

However since yesterday only the "component-window" is visible. My collegues also working with the same environment still see the 3 parts. So it seems to be some "local" change which only concerns me...

Has somebody a solution?

Greetings

Jürg

 

9 Comments

  1. For whatever (undocumented) reason, sometimes the good forms vanish leaving a bit of desaster.

     

    Have a look in your registy for "COMPUWARE" and underneath something like

    "UNIFACE", "STATE", "UDBG" delete the entries there for a "fresh" Debugger window.

    Success, Uli

    mailto: ulrichmerkel@web.de

     

    P.S. maybe if you contact your local CPWR representative,
    you will get better support on features like this.


    Author: ulrich-merkel (ulrichmerkel@web.de)
  2. Hello Uli

    Thanks a lot it worked!

    I deleted in REGEDIT

    • HKEY_CURRENT_USER
      • Software
        • Compuware
          • Uniface
            • USYS9
              • State

    the entry UDBG

    Thank you!

    Jürg

     

     


    Author: jfro (juerg.fross@teamspirit.ch)
  3. You can do this without the registry editor, in a running Uniface App, the IDF or in the debugger.

    Click the icon to the left of the program bar (blue bar) at the top. Choose setup.
    Select the State tab.
    Click 'Delete current layout geometry from settings on app exit'
    Close the app/idf/debugger.

    On closing, it basically does the registry delete itself, but this allows you to do this tweak without giving people access to regedit.


    Author: Iain Sharp (i.sharp@pcisystems.co.uk)
  4. Thanks Iain,

    i new there was a better way, but not which one.


    Author: ulrich-merkel (ulrichmerkel@web.de)
  5. The option in the Setup is newish, before that you had to do the regedit thing.


    Author: Theo Neeskens (tneeskens@itblockz.nl)
  6. Hi Jro, Did you solve your problem? Because I have same problem but I can’t solve it… Somebody help me.


    Author: SilviaMM (silmarmole@hotmail.com)
  7. both ways, the regedit one and the "setup" via the system menu do the job. Just give it a try.


    Author: ulrich-merkel (ulrichmerkel@web.de)
  8. Hi Ulr Thank you , I did both ways, but I can’t see the windows • Watches (left down) • Locals (right down) ¿Is there other settings that I have to review?


    Author: SilviaMM (silmarmole@hotmail.com)
  9. Hi Ulr Thank you, I can see the windows (Watches and Locals). I deleted in REGEDIT the State Laugh


    Author: SilviaMM (silmarmole@hotmail.com)