[SOLVED] winhttp.winhttprequest error

Author: knut.dybendahl@gmail.com (Knut)

So, kinda stumped here... Windows 10 - the following code works flawlessly;

newinstance "WINHTTPREQUEST", vh_webinst vh_webinst->open(psi_method, psi_url, "0") .... vh_webinst->send(psio_content)

In Windows 7, I get a -150 after the call vh_webinst->send(psio_content) and the following is in the msg frame;

ICCDRV-COM-ERR Error with ICC system occurred, The COM method "Send" threw an OLE exception: HRESULT=0x80072f7d, description="An error occurred in the secure channel support ", source="WinHttp.WinHttpRequest": COM error 0x80072f7d, described as "Unknown error 0x80072F7D" (ICC system status: <-2147012739>)

Has anyone come across this?? If so, what was the fix?? Knut

4 Comments

  1. Hi Knut, It seems that the error 0x80072F7D translates to the WinHTTP error 12157 (An error occurred in the secure channel support). If I understand it correctly then the server rejects the connection since the client tries to use an "unsafe" protocol. You should check on the Windows 7 system if the Internet Explorer is allowed to use SSL 2.0 and/or SSL 3.0 (see Internet Options > Advanced under the Security section). If that's the case then make sure that these protocols are disabled (only TLS should be enabled). You can find more details here. Hope this helps. Daniel


    Author: diseli (daniel.iseli@uniface.com)
  2. Hi Daniel, That's a negative. The only protocol enabled is TLS 1.2 - and still no joy. Just for the record, my IE on Win10 had TLS1.0, TLS1.1 and TLS1.2 enabled - and it still works. Removing 1.0 and 1.1 - still works. No SSL enabled at all. Fresh out of ideas... Confused Knut


    Author: Knut (knut.dybendahl@gmail.com)
  3. Hi Knut, Sorry to hear that this did not help. But that's all I could find so far. Then there's probably something else wrong or incorrectly configured on the Windows 7 box. Not sure though what that could be. Maybe you should also ask your question on a Microsoft support forum? Confused Sorry... Daniel


    Author: diseli (daniel.iseli@uniface.com)
  4. Solved.... https://support.microsoft.com/en-us/help/3140245/update-to-enable-tls-1-1-and-tls-1-2-as-a-default-secure-protocols-in#easy Also, there's a 'easy' fix referenced in the above article - can be downloaded as a MSI file (MicrosoftEasyFix51044.msi for those who'd like to Google the fix). Knut


    Author: Knut (knut.dybendahl@gmail.com)