[entities] section

Author: jonathan.degoumois@groupe-t2i.com (Jode)

Hi, I would like to define specific properties for my entities. Is the "[entities] section"  working in the usys.ini file or it is work only with with an ini file specified with /ini Thank you   Jonathan Degoumois

6 Comments

  1. Hello Jonathan, Welcome to the forum. The [entities] section is defined in the assignment (ASN) file and not the INI. For details see (e.g.) the chapter "Assignment File Sections" and related sub-chapters (and related information) in the documentation.  Hope this helps. Kind regards, Daniel Iseli Uniface Support


    Author: diseli (daniel.iseli@uniface.com)
  2. I talk about this [entities] used to set widget properties for the default entity to use udefentity  [entities]

    entstyle_0=udefentity(bordertype=flat)
    entstyle_1.dummy=udefentity(backimage=@..\images\sky.png;valign=center;halign=center)
    person.org.FRM_CONTACT=udefentity(bordertype=flat;backcolor=blue;borderradius=20px)

      thank you


    Author: Jode (jonathan.degoumois@groupe-t2i.com)
  3. Thanks for clarifying this. I did a quick check in it seems that Uniface will read the udefentity settings only from the specified INI-file. So in case you are using an application-specific INI (specified with /ini) then the settings in the usys.ini (in the USYSADM-directory) are ignored, even when the application-specific INI does not have an [entities] section. This is at least what I can see here. I'm currently not sure if this behavior is intended. So in case you are using /ini then you have to make sure that the required udefentity-definitions are in the application-specific INI-file. Hope this helps. Daniel


    Author: diseli (daniel.iseli@uniface.com)
  4. About 10 minutes into this video, I cover some of the entity properties that can be set through the ini file


    Author: Arjen van Vliet (arjen.van.vliet@uniface.com)
  5. Jode said Is the "[entities] section"  working in the usys.ini file or it is work only with with an ini file specified with /ini

    I had another look at this and it seems that this problem already has been recognized as Issue 31136 (UF97: [areaframes] & [entities] not read from default INI when using local INI). At this moment this matter is still unresolved. Hope this helps. Daniel


    Author: diseli (daniel.iseli@uniface.com)
  6. Thank you Diseli. Is exactely the issue 31136.   Jonathan


    Author: Jode (jonathan.degoumois@groupe-t2i.com)