[SOLVED] Uniface Debugger Quick Watch Window Not Showing Up

Author: SPark@cayenta.com (Sang Woo)

Currently running Uniface 9.7. When I run the debugger and want to add variables to my quick watch, the window that pops up when you click on the quick watch menu does not appear. All the other windows such as select watches, browser, etc all pop up normally. Only the Quick Watch window will not show. I thought it could be a hidden window problem so I tried cascading my windows, restarting the application, disconnecting second monitor; nothing helped. Has anyone else had this problem? Any solutions?

5 Comments

  1. Hi Sang Woo, Try this : 1) Close debugger 2) Delete registry key : HKEY_CURRENT_USER\Software\Compuware\Uniface\USYS9\State\UDBG\forms 3) restart debugger Gilles.


    Author: Gilles (gls.tools@free.fr)
  2. Hey Gilles, I don't think it's possible for me to do that, the Uniface application is installed in my company's remote network, not my actual computer. Plus nobody else using the same application through their computers are having any problems with the window not showing, just mine. Thanks for the suggestion though.


    Author: Sang Woo (SPark@cayenta.com)
  3. Hi, The registry key HKEY_CURRENT_USER concern only your PC  : "The HKEY_CURRENT_USER subtree contains the user profile for the user who is currently logged on to the computer. The user profile includes environment variables, personal program groups, desktop settings, network connections, printers, and application preferences."   You can also try to modify Debugger Preferences  (udbg.cnf) :    "On Startup : apply default state" "On Startup : apply last state" or also directly  modify/delete udbg.cnf  but ... be carefull debugger preferences file must be shared on network Wink


    Author: Gilles (gls.tools@free.fr)
  4. In the debugger, click the icon top left in the title bar (of the debugger). In the menu that appears click Setup. Click the State tab. Check the checkbox. State will be deleted when you exit the debugger. Start the debugger again -> form size and location should be normal again.


    Author: Theo Neeskens (tneeskens@itblockz.nl)
  5. Thanks Theo! Your solution did the trick! Quick Watch is back! I didn't end up fiddling with the registry or configuration files, but thanks for your help too Gilles!


    Author: Sang Woo (SPark@cayenta.com)