[SOLVED] Trigger Asynchronous Interrupt - UTIMER component

Author: fvenanciobr@gmail.com (fabricio)

Hello Folks
 
I am migrating my application from uniface 9.4.01 to uniface 9.7.01
 
After some tests, I realized that the form trigger Asynchronous Interrupt does not activated after click my button.
 
My detail button code is (to start the UTIMER component):
 
newinstance "UTIMER", $timer$ $timer$->setMessage($instancename(), "MESSAGE", "") $timer$->setRepeat(0) $timer$->start("00:00:01")
 
The Asynchronous Interrupt code is:
 
if ($msgid = "MESSAGE")   myfield.dummy += 1s endif
 
But this trigger does not activated each 1 second.
 
Interesting that this same code in Uniface 9.4.01 works!!!
 
Any idea?
 
Thanks a lot
Fabricio Venancio
Brazilian Uniface Developer Florianópolis – SC

7 Comments

  1. Hello Fabricio, I did a quick test here and the mentioned code still seems to work fine in Uniface 9.7.01. Confused Did you already debug the code? Are all the statements executed without an error? Thanks, Daniel


    Author: diseli (daniel.iseli@uniface.com)
  2. Hi Daniel I did another form just with dummy and a command button to test, unsuccessfully. Could you export your test form to compare with my component (send to my gmail) ? Thank you! Fabricio Venancio fvenanciobr@gmail.com


    Author: fabricio (fvenanciobr@gmail.com)
  3. Hello Fabricio, I tried it here and also got it to work. The only changes I had to make were to fix the double quotes (") -- but that would have stopped you from compiling... I will send an export to your Gmail account. Regards, Bob Maier


    Author: Bob Maier (bob.maier@uniface.com)
  4. Thank´s Bob I tested your component at runtime, unsucessfully... I think that the are something wrong in my environment.. Could be something about ASN file?


    Author: fabricio (fvenanciobr@gmail.com)
  5. Are you using by any chance NLS? I've found the following issue that currently is unresolved:

    If I'm not mistaken then the mentioned problem can be avoided by making sure that the different NLS settings ($nlslocale, $nlsformat and $nlsinternaltime) are set to "classic" before starting the UTIMER. Hope this helps. Regards, Daniel


    Author: diseli (daniel.iseli@uniface.com)
  6. Hi Daniel Your tip saved me! I put a comment in $nls_internal_time UTC  (ASN file) to solve this problem. Thank you Daniel and Bob   Fabricio Venancio Brazilian Uniface Developer espacodev.blogspot.com


    Author: fabricio (fvenanciobr@gmail.com)
  7. Hi Fabricio, I'm glad I could help. And you are welcome. Regards, Daniel Iseli


    Author: diseli (daniel.iseli@uniface.com)