Problem to store data in DB2[U9.4]

Author: spanish_uniface@hotmail.es (uniface8)

I have a little problem to store some fields en the database.
We are working with U9.4 and the database is DB2, when we make "store" of an entity that is marked as "Automatic" in field list, some fields are filling with null value, but in our asn file we put the parameter USYS$DB2_PARAMS = nullDefault:N and when we mark the entity as "All Fields" it works, and fill the fields with blank value.
¿Somebody knows why it happens?

In U8.4 works fine.

Regards, Rafa.

7 Comments

  1. Hi Rafa,

     

    it looks like the uniface kernel is only aware of the fields in fieldlist.

    Same goes for putlistitems/occ if you have not painted all fields.

     

    Success, Uli


    Author: ulrich-merkel (ulrichmerkel@web.de)
  2. Thank you Uli.

    Then, it´s another bug of U9.4?

     or is it a new way to work?


    Author: uniface8 (spanish_uniface@hotmail.es)
  3. Hi rafa,

    perhaps someone from "the Lab" can answer this.

    Success, Uli


    Author: ulrich-merkel (ulrichmerkel@web.de)
  4. Someone knows an automatic way to change this property in all the entities of the repository?

    I´ trying to find this mark in the repository, but i don´t find it.


    Author: uniface8 (spanish_uniface@hotmail.es)
  5. Good Morning,

    for global update you can use Uniface functionality.

    Go in additional menus to global update, maybe you have to enable them in the generell preferences.

    There you find global update component entities. Here you can set your profile, for e.g. <GOLD>* in the componentname-field.

    Go to the set-properties button. In this form you will find the fieldlist field, where you can set a * (not gold start), if I remember correct.

    Good look

    Thomas


    Author: Thomas.Young (thomas.young@young-consulting.de)
  6. Ty, it works perfectly.

    Regards,Rafa.


    Author: uniface8 (spanish_uniface@hotmail.es)
  7. This is not a bug, but a consequence of the fact that the U3.0 DB2 driver now supports field subsetting. The old U2.3 driver did not, as did early versions of the U3.0 driver, that's why it worked in Uniface 8.

    The nulldefault:N parameter instructs the DB2 driver to replace null values with spaces. But if the field is not painted, and the field list list is 'Automatic', the driver is never instructued to write/update that field, and so has no chance to act on it.

    There is of course the kernel assignment $FILL_DBMS_FIELDS but that does a little bit more, and it applies to all drivers. Not sure if you can use that.


    Author: None (None)