Message :-... - re-establishing connection to URouter ...

Author: lalitpct@gmail.com (lalitpct)

We are getting message as ... - re-establishing connection to URouter ...

step that we did
1)start the applciation
2)kill the process from backend
3)when we hit retrive on the front end we are connecting again

I checked in the docs and it is coming from  $NET_REESTABLISH_MSGID

But the thing is I have not defined any time out (neither on client or on server side)

Does any one have  idea how this can be stopped , as once the process is killed from the back end it should not establish connection again.

5 Comments

  1. I am adding logs as well to understand the problem in a bettre way

    Logs for 8.4
    ================
    (READ) READ:19  if ($formmod = 0)
    (READ) READ:20  read  where "(job_status != 'E' and job_status != 'K' and job_status != 'R' and
    ... - re-establishing connection to URouter ...
    (READ) READ:21  [-21] commit                  <-----------------here network login error is given
    (READ) READ:22  return


    Logs for 9.4
    ===========
    [0](_read) READ:19  if ($formmod = 0)
    [0](_read) READ:20  read  where "(job_status != 'E' and job_status != 'K' and job_status != 'R' and
    ... - re-establishing connection to URouter ...                             
    0](_execute) EXEC:1  $formtitle = "USYSIDX"                 <<---------- here another form used during application start is called ,which it should not

    [0](_execute) EXEC:2  $windowproperties("USYSIDX","STATE") = "STATE=CENTERED"
    [0](_execute) EXEC:3  [-1105] reset $formmod


    Author: lalitpct (lalitpct@gmail.com)
  2. Hello,

    Which patch level are you using? In case you're using the patch R111 (or higher) then you can use the ASN setting $no_db_reconnect in order to avoid an automatic reconnect.

    For more info see the description of problem 29093 ("Option to avoid automatic reconnect needed: behavior changed since fix 27423") on Frontline.

    Hope this helps.

    Kind regards,
    Daniel

    *** Usual disclaimer ***

     


    Author: diseli (daniel.iseli@uniface.com)
  3. I tried below setting in client asn ansd its not working ,


    [SETTINGS]
    $variation=SMART
    $language=USA
    $GUI=MSW
    $enhanced_edit=all
    ;$SEARCH_DESCRIPTOR = file_first
    $swap_gold_profiles
    $timeout   = 30
    $transcript_logfile   = C:\Users\Ld78977\Desktop\LalitSingh\guiAIXunixasia94\asiadev94.txt
    $putmess_logfile     = C:\Users\Ld78977\Desktop\LalitSingh\guiAIXunixasia94\mess.log
    ;$IOPRINT   =511
    $IOPRINT   =63
    $proc_tracing            =TRUE
    $proc_tracing_addition   = [%%$status]
    $NO_DB_RECONNECT
     


    Author: lalitpct (lalitpct@gmail.com)
  4. I had applied patch w32r113 , do you know how to set it up in asn files ?


    Author: lalitpct (lalitpct@gmail.com)
  5. When I put at

    client asn ---> it doesnt not have any effect

    server asn --> The urouter is not connecting to the server

    urouter.asn --> we cant start urouter itself

    Please let me know how this can be fixed , as it has comletely halted the progress.

    Its a serious issue , i have installed w32r113 which claims that it has fixed this issue.

     

    The way I am putting

    [SETTINGS]
    $ioprint=256
    $SEARCH_RESOURCES = resources_excluded
    $NO_DB_RECONNECT


    Author: lalitpct (lalitpct@gmail.com)