Problem with DSP[U9.4]

Author: spanish_uniface@hotmail.es (uniface8)

Hi all, I have a problem with DSP, when I copy an entity or a field as HTML and paste in source or graphic editor always appears this message:
"Error in widget definition"

Someboby knows why?

I can work with USP normaly.

Regards,Rafa.

6 Comments

  1. Hi

    IDF don't know how to do the paste. It gains this definitions from uweb.ini, which seems not to be available (don't forget uproperties.ini too).

    Kind regards,
    Richard


    Author: richard.gill (richard.gill@agfa.com)
  2. As Richard said, the IDF probably can't find uweb.ini where this information is kept. This is usually caused by not having the \adm switch set on your IDF shortcut. By default it should be set to something like "C:\Program Files\Compuware\Uniface 9.4\uniface\adm".


    Author: James Rodger (james.r.rodger@gmail.com)
  3. The only time I have seen this is when there is no widget type defined in the properties for the field.
    Regards, Mike


    Author: Mike Taylor (michael.taylor@uniface.com)
  4. Hi, i tried that, i added the /adm switch and nothing changes, i tried to join the ini files,...
    It´s strange, because when i convert an USP to a DSP works, i can see all the USP widgets in the graphic editor, and if i test the DSP, it works, but if i add a field in graphic or source editor of this DSP appears the same message "Error in widget definition".

    Regards.


    Author: uniface8 (spanish_uniface@hotmail.es)
  5. Finally I had time to see why this happend to me,  I reinstalled uniface and  I added the /adm switch and it works.

    Ty for your advices.

    Regards,Rafa.


    Author: uniface8 (spanish_uniface@hotmail.es)
  6. Hi Rafa,

    Thanks for letting us know what the solution was.


    Author: James Rodger (james.r.rodger@gmail.com)