1
0
-1

Hi all,


In previous versions of Uniface the Fieldlist property of all painted entities were automatically set to All fields. This was accomplished by changing this setting this property of the USUPERTYPEDEF entity on the UFRMDEF component.

We migrated our Uniface defaults from Uniface 9 into Uniface 10. But when we paint an entity on a form component, the Fieldlist is Automatic. We need this to be All fields for all painted entities. Does anyone know where we can change this default setting? I tried different Uniface defaults, but found none.


Thanks in advance,

John Bergsma

    CommentAdd your comment...

    2 answers

    1.  
      1
      0
      -1

      Hi John,

      insert in your developer.asn this

      [SETTINGS]

      $V7Include_field=true

      It´s old but it working.

      regards

      Harry

        CommentAdd your comment...
      1.  
        1
        0
        -1

        Hi John,

        The way defaults work in version 10 has changed from version 9. In version 9 you had a single default object from which all objects of the same type would be created. In version 10 you are able to create many templates/pallets giving you much greater flexibility. To see the temples and pallets in the IDE you will need to set the logical ALLOW_BROWSE_TEMPLATES = 1 in your asn file. With this logical set, you will be able to open ent:UENTDB.MODEL and update the defaults.

        Kind regards,

        Mike

        1. John Bergsma

          Hi Mike,


          I know I have to add ALLOW_BROWSE_TEMPLATES = 1 in the asn file. And found UENTDB.MODEL as well, But in UENTDB.MODEL it is not possible to set Fieldlist to All fields, the property is not shown in the entity object settings. I think I have to set it somewhere else where like cpt:U?FRM / cpt:U?FRN, but on these components there is no entity defined on which to set the Fieldlist property.


          Kind regards,

          John

        2. Harry Fuchs

          Hi John,

          insert in your developer.asn this

          []

          $V7Include_field=true

          It´s old but it working.

          regards

          Harry

        3. Mike Taylor

          Hi John,

          A common way of painting entities in Uniface 10 is to paint the "Empty Non-DBMS Entity" from the template cpt:UPALETTE_FRM and renaming the entity to match the modelled entity name. As the "Empty Non-DBMS Entity" template basically has no properties set by default it will inherit everything from the modelled definitions.

          If you wanted a template which by default had the field list set to * then duplicate the cpt:UPALETTE_FRM and update the "Empty Non-DBMS Entity" (ENTITY.NOMODEL) or create a new entity template of your own.

          Kind regards,

          Mike


        CommentAdd your comment...