1
0
-1

Hey all,

We're running Uniface 9.6.05.02.  Is this version compatible for Oracle 19c?

    CommentAdd your comment...

    2 answers

    1.  
      2
      1
      0

      Well....

      It depends;

      If you can lay your hands on a 12.1 Oracle client - and use the Uniface U7.1 driver - you should be good;

      Uniface 2 Oracle Driver Question - August 9th, 2021

      Regards,

      Knut

      1. Marcelo Wohlke

        Thanks Knut,

        But, have you ever tried using U71 with client 19c to access Oracle 19c?

      2. Knut Dybendahl

        I'm pretty sure that wouldn't work because the UF 7.1 driver was compiled with the 12.1 client.

        The Oracle compatibility matrix states 12.1 client will work up to 19c - as long as you don't want

        to make use of any new features after 12.1. 

        I''ve faced the same predicament here - so we're sitting on 12.1 client when we move to 19c this fall.

        HTH - Knut

      3. Marcelo Wohlke

        Thank you very much!


        MJW.

      CommentAdd your comment...
    2.  
      2
      1
      0

      Hi Marcelo,

      The latest version of Oracle that was supported in the 9.6 code line was Oracle 12c, which was introduced in patch MX03. Uniface 9.6 Product Availability Matrix.

      Kind regards,

      Mike


        CommentAdd your comment...