1
0
-1

Hi,

We have had an internal security scan run on our environment and flagged a number of Tomcat 9.0.X vulnerabilities and advises us to upgrade. Can anyone advise what version of Tomcat 9 (or 10) is supported on Elucid 9.7.05 and if there are any steps/instructions to do so? I can see the instructions for upgrading from Tomcat 8 to 9.


Regards,

Nick

    CommentAdd your comment...

    2 answers

    1.  
      1
      0
      -1

      HI Mike,

      Thank you for the reply.

      I have already seen that link but it is for tomcat 8 to tomcat9 but I wish to see about upgrading to a later version of tomcat9 to cancel out some of the vulnerabilities of the version of Tomcat 9. It is likely the same steps but wanted to check if someone could confirm this.


      Regards,

      Nick

        CommentAdd your comment...
      1.  
        1
        0
        -1

        Hi Nick,

        Uniface supplies a version of Tomcat to offer an out of the box development experience, but Uniface can run on any webserver supporting the JAVA Servlet API version 2.3 or 3.0 - Uniface Web Application Server.

        There was an article published a little while ago explaining how to update your Tomcat version which maybe of use - Apache/Tomcat 8 Uniface Migration Guide.

        Uniface 10.4 will be delivered with an updated version of Tomcat.

        Kind regards,

        Mike

          CommentAdd your comment...