1
0
-1

Uniface 9.7.05.043; SQL Server 2017

I have an editbox that is sized as 20 x 2

It is a String field; it is non-database; interface is C40 and it starts out as Hidden

Properties are: Automatic Work Wrap = T; Transparency = T; Hover View = T; and Multiline = T

Widget Font = Arial Westernpt 10

When we want to show the field, we populate it with the appropriate text and turn on the syntax to show the data.

For example:

leak_test_info.icon_alley = "Leak Test Due in 7 days"

$fieldsyntax(leak_test_info.icon_alley) = "YDI·;NED·;NPR"

What shows up is: "Leak Test Due in"

I then tried this, with same result:

leak_test_info.icon_alley = "Leak Test Due in %%^%%%7 days"

If I hover over the field I see: 

     Leak Test Due in

     7 days

Is it not working because I'm using a special font?


Thanks!

Joanne DeTurk

Mirion Technologies




    CommentAdd your comment...

    1 answer

    1.  
      1
      0
      -1

      Dear Joanne,

      Not sure if this issue is still is current.

      Anyways, I did a quick test here and the word wrap seems to work as expected (in the scenario you're describing). Did you already check what happens when you step through the content of the edit box using (e.g.) the right arrow key? Is there a new line or not? If you're using an explicitly new line ("%%^") then you should see this as well when zooming the edit box field.

      I'm not sure what's going on here, but is it possible that the text is clipped since it cannot be shown completely in the available space? Although, I remember that Microsoft has changed something in Windows 10 recently. Before an edit box only showed the text if it completely fits in the available space and with the latest updates the text is now shown even when the lower half is partially truncated.

      I hope this helps.

      Kind regards,
      Daniel

        CommentAdd your comment...