from frontline: obsolete OS and DBMS planned for 9.6

Author: ulrichmerkel@web.de (ulrich-merkel)

Just for those who do not check frontline on a regular base, there is some "call for feedback":

 

Source: http://frontline.compuware.com/products/uf/tech/30051.aspx

Deployment technologies planned to be discontinued in the release of Uniface 9.6


As part of the planning for the release of Uniface 9.6, there are a number of deployment operating systems and databases which are supported by Uniface 9,5, but we are considering to discontinue with the release of Uniface 9.6.

The reason why we are considering discontinuing these is because the technologies are obsolete, out of support, etc, etc.

Operating systems that are suggested NOT to be supported with Uniface 9.6:

  • Windows XP
  • Windows Vista
  • Windows Server 2003
  • SuSE linux Enterprise Server 10
  • Redhat Linux 5.0-5.4
  • IBM AIX 5.3
  • HP Itanium OpenVMS 8.2
  • IBM iSeries V5R3

Databases that are suggested NOT to be supported with Uniface 9.6:

  • Ingres 2006
  • LDAP 3.0 (u1.0 driver)
  • Oracle 10
  • MS SQL Server 2005
  • MySQL 5.0
  • Sybase 12.5 Solid 4.5

If you feel that Uniface should continue to support these technologies with Uniface 9.6, please contact your Uniface representative to discuss.

3 Comments

  1. As a freelancer, I have some insight on different customers development and production environment.

    Personally, I still run all my development (over a couple of uniface versions) including tests on a XP box which served me well for years now.

    And I have seen a lot of customers still using XP boxes for production purposes (simple to handle, financially written-off, custermers are used to use it). .
    I wonder what these customers will tell us when they have to upgrade not only the software, but the hardware as well to get the benefits of the U96 world.

    Think this will become another sharp divide of people "sitting" on a specific version for years (just what we have with some U7x customers).

     

    Beeing a Solid enthusiast from tha day it was introduced in Uniface, I would like to keep at least SOL45 for some more time.
    We have 3rd party combinations outside which may cause problems when the database version is no longer supported.


    Author: ulrich-merkel (ulrichmerkel@web.de)
  2. We are stuck on U8 due to the legacy systems we exchange data with that are on several old versions of Oracle. (7,8,9,&10)

    Each time Uniface drops support for these older versions it makes it less likely we will ever be able to upgrade our version of Uniface. 

    We have plans to replace the legacy systems on Oracle 7 & 8 sometime late 2014. By then I'm sure more database support will be dropped leaving us forever on an unsupported version of Uniface.


    Author: dmanchester (dave.manchester@nucor.com)
  3. Some uniface customers may have to invest in HW/OS/DBMS because of the dropped uniface support with 9.6 if they will not become dinosaurs.

    Most of them want to invest only the absolute necessary money and expect that this will be sufficient for the next 5+ years.

    In this context, it would be extremely helpful if we know which HW/OS/DBMS versions will be supported with U96+ as well as U10+.

     

    Would be very nice if CPWR can provide this commitment pretty fast,
    because investments in nowadays financial situation is a very longlasting task.


    Author: ulrich-merkel (ulrichmerkel@web.de)