The heartbleed fix in patches X402S and E123S, service pack MX04 and version 9.6.05

Author: Jan Cees Boogaard

For the heartbleed fix in patches X402S and E123S, service pack MX04 and version 9.6.05 to be effective on UNIX and Linux machines, Uniface has to use the libssl.so library that is included in these patches. It is possible that a different, vulnerable, libbssl.so is installed on a machine.   Whether the right libssl library is used can be checked in the following way:  

  1. Source the insunis script to make sure their environment includes the Uniface paths correctly.

. <Uniface install directory>/adm/insunis  

  1. Check the dependencies of the libcurl library in the Uniface /lib directory.

cd <Uniface install directory>/lib ldd libcurl.* | grep libssl  

  1. If the output looks like this, then Uniface is using the library delivered with Uniface

libssl.so => <Uniface install directory>/lib/libssl.so

This page has no comments.