Support for Windows 8.1 and Windows Server 2012 R2

Author: daniel.iseli@uniface.com (diseli)

From Frontline: http://frontline.compuware.com/products/uf/tech/30130.aspx Patch MX03/Uniface 9.6.04, planned for December 2013, will provide Uniface 9.6 support for Windows 8.1 and Windows Server 2012 R2. Patch E121, planned for November, will provide Uniface 9.5 support for Windows 8.1 and Windows Server 2012 R2. We are not planning to provide support for Windows 8.1 and Windows Server2012 R2 on unsupported Uniface versions.

5 Comments

  1. Service Pack MX03/9.6.04 installable Dec 18, 2013/Dec 27, 2013 Planned What's meant by this, is the Service Pack ready before the installable? Will Uniface 9.6.04 be available in December 2013 or is it late? By the way, I think I understand the reason to this strong coupling of Uniface versions to an operating-system, but wouldn't it be enough to give a warning if someone tries to start on a non-supported operating-system and then let it start? Regards RogerW.


    Author: rogerw (roger.wallin@abilita.fi)
  2. Hello RogerW, The Service Pack MX03 has been released today (December 18) and it can be installed on top of any Uniface 9.6 installation (regardless of the patch level). The 9.6.04 installable (also known as e-dist) is meant for new installations and it includes the complete product. Since I have not heard anything to the contrary I assume that the installable will be available as announced on December 27, 2013. And I cannot really comment on your last question. Product Management (Adrian) is better suited to provide an answer for this. Hope this helps. Regards, Daniel


    Author: diseli (daniel.iseli@uniface.com)
  3. Ok, thanks Daniel! We will hear what Adrian has to say. Uniface has become a real pain for us, customers updating their operating systems and then not being able to start the applications. I have to admit that I don't understand that the difference of eg. Windows 8.0 and Windows 8.1 would be so big, that you can't even start without an Uniface update. As the licenses nowaday are also really short-lived, I think we nowadays put too much time on updating licenses and testing old applications on new Uniface releases. Have I understood right that you need Uniface 9.6.04 to install MX03, you can't use 9.6.01? Regards RogerW.


    Author: rogerw (roger.wallin@abilita.fi)
  4. Hello RogerW,

    rogerw said Have I understood right that you need Uniface 9.6.04 to install MX03, you can't use 9.6.01?

    That is a misunderstanding. The Service Pack MX03 can be installed on top of any Uniface 9.6 version < 9.6.04. I.e. * Uniface 9.6.01 + MX03 = Uniface 9.6.04 * Uniface 9.6.02 + MX03 = Uniface 9.6.04 * Uniface 9.6.03 + MX03 = Uniface 9.6.04 The 9.6.04 installable (or e-dist) is intended (more) for customers that do not use version 9.6 yet and would like to upgrade. Hope this helps. Regards, Daniel


    Author: diseli (daniel.iseli@uniface.com)
  5. Thanks Daniel, that clarified my question, I don't know from where I had got that you should install MX03 only on 9.6.04??? By the way, I like your easy migration process, It has been working well for 20 years, at least for desktop applications (don't know about web). We still have some forms that initially were developed for DOS, of course modified a bit. I also understand and accept the need to get Uniface users together to new versions, although I think that it shouldn't be exaggerated. Regards RogerW.


    Author: rogerw (roger.wallin@abilita.fi)