Unzip DOL response time

Author: oppenheimyaron@gmail.com (yarono)

Hi,

Our client has recently upgraded their servers to Windows 2008 and they
got a response time problem regarding to startup our Uniface application.
On client computers it's takes over a minute.
The DOL and URR files located on a network file server.
When we change the location of the DOL file to another directory on the server, the problem is solved only for a few hours.
When we open the DOL file (that located on the server) from the client computer by using WinZip software we got the same response time problem.
 
Do you have any idea why this happens or dealt with this problem ?
Thanks,
Yaron O.

8 Comments

  1. Hi Yaron,

    you will find a lot of issues on uniface.info about this here: http://uniface.communityzero.com/uniface?go=2399138


    Looks like the problem is caused when the network file server runs under non-windows.

    Transfering the DOL file to a windows based fileserver will curre the problem immediately.

    Only this file, a tiny (old and grey) windows box in the network will do the trick.

     

    There is already a wish (and I suppose some calls) on that issue.

    Uli


    Author: ulrich-merkel (ulrichmerkel@web.de)
  2. Hi Uli,

    Thanks for the quick replay.

    The file server and the clients are pure windows.

    It seems taht the problem began after upgading the file server to Win 2008.

    Yaron


    Author: yarono (oppenheimyaron@gmail.com)
  3. Hi Yaron,

    that scatters all the believers of windows-will-cure-it.

    Just for curiosity:

    Are there some system settings in your file server about Unicode,  "store compressed", or so

    which may confuse the clients ZIP routines

    (great to hear that anotter tool takes ages as well to unzip the file so it's not only uniface)

    Uli

    P.S. and for exeperiements: what happens if you have this DOL locally on the client?


    Author: ulrich-merkel (ulrichmerkel@web.de)
  4. Dear all,

    We faced the same issue. The resolution : Copy DOL (and URR) on each Windows Server 2008.

    (we use TSE for the access on applications)

    Now, it's correct.

    Regards

    Antoine Picaud


    Author: apicaud (antoine.picaud@free.fr)
  5. so you have the DOL and URR copied to each client box to get an acceptable startup time.

     


    Author: ulrich-merkel (ulrichmerkel@web.de)
  6. Hi  Antoine,

    Thank you for your response that supports my suspicion that the problem is in Windows 2008.

    Our system manager try to check it out but he doesn't find yet the cause of the problem.
     

    Regards,

    Yaron O.


    Author: yarono (oppenheimyaron@gmail.com)
  7. Hi,

    We have the same problem.

    We are thinking in the direction of our Anti-virus software (Mc Afee) which perfoms an on access scan on all zipped files ?

    Regards,

    Steven

     


    Author: Steven.Konings (steven.konings@imec.be)
  8. Hi Steven,

    but the problem is gone as soon as you have a local copy.

    Think this excludes any issues which run on your local box as well as on the fileserver (like AntiVirus).


    Author: ulrich-merkel (ulrichmerkel@web.de)