Urouter sid=0 is dead

Author: dennis.vorst@uniface.com (Dennis Vorst)

Hi, I am currently working on a small project using windows 7 and Uniface 9.6.01. After i restarted my computer the web application i build didnot display in the browser anymore. I got a RSOD (Red screen of death). After shutting down my Zonealarm firewall the application started working again. But... I restarted my computer again. And shut down the firewall. And then tried to run the application. But it times out with the RSOD showing 300 URD_MW_ERROR Middleware : UV8 Error# : -25 Error Text : see UNIFACE message guide I went to services stopped the U96 Urouter, Tomcat and Solid. In that order. And restarted the Solid DB, Tomcat and urouter (in that order). But it still times out. The WASV logfile says: DNP Logon (TCP:.<PC_NAME>wanadoo.nl+13002|userver|B0C9B3A2-538E-4B8C-9D69-09E5482552A6|wasv -drv=ANY) failed with status -18, Failed to connect to URouter Fatal error: 9024 - Application stopped due to logon error. Fatal error: 9024 - Application stopped due to logon error. I am really stumped: - i didnot make any changes in the code of my application - i made no changes to the Uniface environment - i did not change anything on my PC. No configuration changes, no software installations. - the apache tomcat is available at localhost:8084. ie it displays the Apache content - i am using a small DSP container with only HTML and no difficult or heavy processing - i did recompile the components several times Suggestions are welcome.


  1. well it appears that my hostname in the logon TCP:hostname+13001... was showing mi PC Name + the DNS suffix (pcname.cantv.net), so i modified my hosts file and added this line:     pcname.cantv.net. Problem solved!!! 

    Author: bioalexy (ablancouribe@compuamerica.com.ve)
  2. https://www.youtube.com/watch?v=apxN5-L-XPI A good place to start First quick check (based on your error) The userver (and urouter) are run within local accounts.  Go to Control Panel - Administrative Tools - Computer Management - Local Users and Groups and check that the accounts are not locked out for any reason.

    Author: None (None)
  3. Hi,  I am having the same error using Uniface 9.6.05, did you manage to solve it?

    Author: bioalexy (ablancouribe@compuamerica.com.ve)