U9.4 on Windows 2012r2 e W8.1

Author: marco.aquino@dedalus.eu (Marco)

Hi, I need to know if windows 2012r2 and W8.1 are supported by U9.4. I red on compuware site http://frontline.compuware.com/products/uf/tech/30130.aspx that U9.4 not support w2012r2 and w8.1. I red on patch R136 the bug 30512:  Uf versions 9.3.02 and 9.4.01 should run on Windows 8.1 Description:  Enabled support for Windows 8.1  The Uniface license mechanism requires an update to enable support for Windows 8.1 on Uniface 9.3 and Uniface 9.4 Solution:  This problem is solved. So with This problem is solved, I think that w8.1 is supported and I hope w2012r2 also. Can anyone confirm this? Thanks in advance Marco

6 Comments

  1. Adrian Adrian Thanks for your time, now all is clear. Thank's a lot   Marco


    Author: Marco (marco.aquino@dedalus.eu)
  2. Thanks Marco, I think I understand. This is about Uniface 9.4 support of Windows 8.1 (rather than 8.0) and Windows 2012 R2 server (rather than 2012).  This isn't on the PAM because we have not verified that Uniface 9.4 runs on these platforms.  That was because Uniface 9.4 has been out of support since June 2013. Both Windows 8 was updated to be Windows 8.1 and Windows 2012 R2 was released in October 2013, so after EOS.  After some requests from customers, we released patches to enable Uniface to run on the MS Maintenance, but as Uniface 9.4 is out of support the verification process was not executed and therefore the PAM was not updated.  Using Uniface 9.4 on these platforms is fine as far as I am aware, as I've not heard otherwise, but the onus would be on you to ensure there are no issues with your application. 


    Author: Adrian Gosbell (adrian.gosbell@synapse-i.jp)
  3. Adrian Thanks for your time, but in the file PAM95 there are specific columns for W81 and W2012R2, missing in PAM94. I think it's just a matter of updating. the file PAM94 is 31 jan 2013 while the patch R136 was released on 27 dec 2013. I think it's necessary to patch R136 for use on W81, but I need to know if it works on W2012R2 also, because in the other versions (95,96) is the support of the two platforms together.   Marco


    Author: Marco (marco.aquino@dedalus.eu)
  4. You can download the Product Availability Matrix (PAM) for Uniface 9.4 and it will confirm the platforms which were supported by Uniface 9.4. 


    Author: Adrian Gosbell (adrian.gosbell@synapse-i.jp)
  5. Adrian Gosbell said You can download the Product Availability Matrix (PAM) for Uniface 9.4 and it will confirm the platforms which were supported by Uniface 9.4. 

    Hi Adrian, I download that file where W8.1 and W2012R2 aren't present, but on patch R136 there is a solved bug for W8.1 (see message above), so the matrix isn't updated?   Marco


    Author: Marco (marco.aquino@dedalus.eu)
  6. Hi Marco, this might be an misunderstanding on how currency support is reflected in the PAM or I don't understand what you are asking.  This is a cap from the most current PAM for Uniface 9.4. (PAMs are on this site nowadays. The Frontline site isn't updated as it's a Compuware site and we are gradually moving everything to this site).  9.4PAM Screencap Where the patches are reflected, this means in effect from this patch, the technology is supported.  Using this screen cap as an example, Uniface 9.4 can run on Windows 8.1 since the release of patch r131 and every patch released afterwards. It could be at additional databases had support introduced afterwards, so that particular combination would be effective from a different patch.  If this doesn't answer your question, either contact support or your account manager. Or you can you contact me directly and I'll get somebody to contact you to help you. 


    Author: Adrian Gosbell (adrian.gosbell@synapse-i.jp)