Uniface Anywhere and Windows Server 2016

Author: jraymond@empowersis.com (jraymond)

Looks like the path variable is set by Uniface Anywhere on Windows server 2016. This means that any custom paths set on the system is over written. I tried to set it by a login script as well and it was not used there or was over written. Opening a command prompt and setting the path to what i want worked for that command prompt but did not help any other applications i attempted to open through Uniface Anywhere. This prevents Uniface Application that use Oracle from working as the dll is not found. Is there a solution in the works? Is there a work around?

1 Comment

  1. A workaround to this issue is could be: Create a start cmd file for Uniface that will extend the local path. ----------example uniface.cmd------------------------------------ @echo off setlocal path=%PATH%;c:\oracle\product\11.2.0\client_1\bin;c:\oracle\product\10.2.0\client_1\bin c: cd \jti-9702 start /MAX /WAIT C:\U9702\common\bin\uniface.exe /adm=c:\u9702\uniface\adm /ini=c:\UA-9702\_usys.ini /asn=c:\UA-9702\_usys.asn UA %username% %userdomain%   :QUIT Endlocal --------------------end example uniface.cmd--------------------------   Place this command file on the Uniface Anywhere Host and make sure that all users can read access this file. Publish within Uniface Anywhere Cluster Manager this command file as: Executable path: C:\WINDOWS\system32\cmd.exe Start Directory: C:\WINDOWS\system32\ Command-Line Options: /c c:\testapp\uniface.cmd   In the command file there is the /WAIT statement. If it is removed, than the command box will be closed directly after starting Uniface.


    Author: Nico Peereboom (nico.peereboom@uniface.com)