Author: email@example.com (istiller)
So, now I'll start a survey Is out there any preferred naming conventions of operations? As in other languages I named an operation which does some display "DISPLAY" and another one printing will named "PRINT". So an activate looks like: activate v_INST."DISPLAY"(...) or v_handle->"DISPLAY"(...) But the disadvantage is, that UnifAce editor highlights this like any other "display" statmenent. So I thought about OP_DISPLAY, OP_PRINT, OP_xyz, ... And as will all know, one drawback of UnifAce is, there is no overloading of functions. Say, there is the need for two PRINT-Operations OP_PRINT(a_parameter_typ1) and OP_PRINT(a_parameter_typ2) Okay, the only solution so far in UnifAce is two write two Operations OP_PRINT1 and OP_PRINT2 So the survey is:
- how do you name operations in general?
- how do you name such overloaded functions?
Any hint / comment is appreciated Ingo