disabling SQL workbench

Author: paolo.sangiovanni@marpsrl.it (paolo)

Hi folks, I would like to disable the default Uniface SQL workbench or, at least, substitute the default form with a customized one. I tryed without success to change the keyboard translation table ( my $variation=SOS and $keyboard=MSWINX and I edit the MSWINX.SOS KTT) : ^130W ^QUIT instead of ^130W ^SQL Uniface.exe seems to ignore the changing (note: if I change e.g. the F2 key it works!). My second attempt was to redirect the sql workbench form to a new one, changing the .asn file in the [FILES] section: usys:usyssql.frm usys:mysqlform.frm nothing... uniface with GOLD+W continues to open the default form, it seems the key combination is hardcoded into the runtime executable. Anyone had the same problem? Frown thank you in advance for your help Paolo

4 Comments

  1. in uniface 7, i used the following ASN to put my own form instead of the SQL workbench (and keep the workbench open with a new name): Please note that at the end, I included the USYS:USYS.ASN again, I think it was because otherwise the redirection has not worked [FILES] *\* *\* USYS:USYSSQL.FRM USYS:..\UG_ZUSATZ\UG_CSUP.FRM UG_SQL.frm USYS:USYSSQL.FRM UG_*.frm USYS:..\UG_ZUSATZ\UG_*.frm #file USYS:USYS.ASN [SETTINGS]


    Author: ulrich-merkel (ulrichmerkel@web.de)
  2. Greeting. I don't know if this is offtopic for this thread but, I need to disable de Sql Edit from our Uniface Runtime Environment (opened by Ctrl + W), do anyone know how to disable it. Thanks.


    Author: Sergio Encinas Benítez (sergio_enbe@hotmail.com)
  3. Hi, in the keyboard translation table change the Ctrl+W setting from ^130W ^SQL to: ^130W ^NUL and add the following line at the bottom of the table: ^GOLD^wW ^NUL It has worked for me for many years. Copy the in use keyboard table from the USYS library to your project library. Make the modifications in the copy so as not to change the usys defaults. Remember you may need to load sources to be able to "see" the keboard table. For Windows platforms this is normally MSWINX from USYS to your project library - keeping the same name or, if you change it, use $keyboard settings in your assignment file.


    Author: None (None)
  4. daveyex said Hi, in the keyboard translation table change the Ctrl+W setting from ^130W ^SQL to: ^130W ^NUL and add the following line at the bottom of the table: ^GOLD^wW ^NUL It has worked for me for many years. Copy the in use keyboard table from the USYS library to your project library. Make the modifications in the copy so as not to change the usys defaults. Remember you may need to load sources to be able to "see" the keboard table. For Windows platforms this is normally MSWINX from USYS to your project library - keeping the same name or, if you change it, use $keyboard settings in your assignment file.

    Thank you, this worked for us perfectly. Laugh


    Author: Sergio Encinas Benítez (sergio_enbe@hotmail.com)