Uniface 9.4.1 Trial Version

Author: bignonj@gmail.com (Bignon)

Hi,

I would try Uniface 9.4.1 Trial version. The license file is correctly. Solid and Idf ok.

When I start Uniface Developpement, I get :

"8008 : Assignement statement error '$DBMS=SEQ||' .... A user is missing ?

 

 

Thanks for all your responses,

 

Jérôme Bignon

Nantes - France

 

12 Comments

  1. Hi Jérôme,

    in the old days, you run through an interactive session where you could define your SEK and database defaults.

    Looks like this has not happened in your case and the SEQ-driver is not enabled in the TRIAL sek.

    You can modify under the installation directory dbms.ini, usys.asn and usys.ini.

    In 9.4.01 these files can be found in COMMON/adm as well as UNIFACE/adm.

     

    Checked it in my installation, dbms.asn points to SOLid, as expected.

    SUccess, Uli


    Author: ulrich-merkel (ulrichmerkel@web.de)
  2. Hi Jérôme

    Juste move the assignment to :

    $DBMS = SEQ:

    all will work with the SEQ driver, but you should have a solid driver if solid was installed before. I never install solid for a 9.4 Uniface installation, so I can't tell if it's a general case.

    In the common/adm/dbms.asn you should have a commented line :

    $DBMS_SYS    SOL:nmpipe Uniface_94_Development_Solid_Database:|uniface|nine

    Modify your assignments to point to this database and all should work:

    $DBMS $DBMS_SYS
    $SYS    $DBMS_SYS
    $UUU   $DBMS_SYS
    $DEF    $DBMS_SYS
    $IDF      $DBMS_SYS
    $WFM   $IDF

    Don't forget to comment the [Entities] part :

    ; *.* = $DEF:...

    Kind regards,
    Richard (from Ancenis, near Nantes :)


    Author: richard.gill (richard.gill@agfa.com)
  3. Thank you both, I'll try your solutions as soon as I can...

    Until there, merry New Year

     


    Author: Bignon (bignonj@gmail.com)
  4. Hi all,

    to find out experiences with the trial version,

    I got a brand new machine (Asus eee Box, not too expensive and portable)
    where I can use the recovery-function to reset to a brand new Windows XP.

    To explore some "minimal effort" situations and experiment with diferent uniface environments.

    I will not care too much to set up proper directory structures, additional ASNs etc.
    but use what the uniface installation gives us immediately
    without digging too much in the internals of operating systems or uniface installation structures.

    I know all of us working for years with uniface (like myself) will start with:

    - creating project directories for their own
    - have a nice set of subdirectories
    - a project.asn and a project.ini

    But I want to go straight to the point where we can experiment with out-of-the-box Uniface Trial .

    SUccess, Uli

    101227: First PDFs available


    Author: ulrich-merkel (ulrichmerkel@web.de)
  5. You may have problems with the SOLID database after a couple of days because of the SOLID evaluation license conditions.

    Just copy the SOLID.LIC you got with the uniface sek to

    C:\ProgramData\Uniface 94 Development\project\dbms

    SUccess, Uli

    P.S. This and other tips you can get from http://www.uli-merkel.de/dito9401trial/

     


    Author: ulrich-merkel (ulrichmerkel@web.de)
  6. Hi,

    So, it's ok for my first Form in U941...

    This is my dbms.asn, as Richard said :

    [DRIVER_SETTINGS]
    SOL     U3.4
    SEQ     U1.0
    [PATHS]
    $DBMS_SYS    SOL:nmpipe Uniface_94_Development_Solid_Database:|uniface|nine
    ;$DBMS_SYS    SEQ||

    $DBMS = SEQ:

    $SYS    $DBMS
    $UUU    $DBMS
    $DEF    $DBMS
    ;$IDF    $DBMS_SYS
    $IDF    $DBMS
    ;- $WFM, used for the Uniface Flow instance data, must use the same path as $IDF:
    $WFM    $IDF

    [ENTITIES]
    ;- The following line must be removed when assigning the DB paths to a (relational) DBMS:
    ;*.*      $DEF:C:\ProgramData\Uniface 94 Development\project\dbms\*.*

     

     

     

     

    I seem that solid.lic is only ok for a few days... So I'm using SEQ.

    I'm going to try then the Dynamic Server Page.


    All my best for 2011 !!

    Happy New Year !! Bonne Annnée !!

     

    Jérôme Bignon - France


    Author: Bignon (bignonj@gmail.com)
  7. Hi Jérôme,

    I still could not reproduce your SEQ installation.
    I installed uniface on a brand new windows XP home w/o any problems.

    With the TRIAL SEK you got a solid.lic lasting up to 14-feb.
    Looks like the licens has not suffucient connections allowed:
    when I start the IDF, it reports "too many connections" problem.

    Stopping the database service and restarting it will solve the situation:
    IDF is running in all it's glory.

    If you are interested, I put my experiences
    *** plus some experimentson different kinds of remote activation ***
    on www.uli-merkel.de/dito9491trial.

    It's work in progress, as usual when it comes to dITo

    SUccess, Uli

     

     


    Author: ulrich-merkel (ulrichmerkel@web.de)
  8. Hi Uli,

    About Solid, I get this message when I start Solid Database Engine :

    "SOLID System Fatal Error 11014 : Database age limit of evaluation license expired"...

    So, I have set in dbms.asn file the paramterers for SEQ as Richard said.

    One stupid question : What is extactly SEQ ?

    Second stupid question : I'm testing the Dynamic Server Page. I created a new model with two entities. Ok. How to put one entity in the DSP ?

     

    To get back on Solid :

    - Where I put the solid.lic ?

    - Would look like dbms.asn file if I use Solid ?

     

    Thanks for your response, as usual.

     

    Jérôme Bignon

     

     

     

     


    Author: Bignon (bignonj@gmail.com)
  9. Hi Jérôme,

    SEQ is a "sequential" driver, just flat files, no transaction, just nothing at all.

     

    So comming back to the SOLID questions:

    If you have a standard 9.4.01 installation with all the defaults,

    C:\ProgramData\Uniface 94 Development\project\dbms is the place for your solid.lic

    Your DBMS.ASN (I got if during my development) should read as:

    **********************************************************************************************************************

    ;- Development database

    [DRIVER_SETTINGS]
    SOL     U3.4
    SEQ     U1.0

    [PATHS]
    ;-  In particular for Uniface Flow (i.e. for the 'Process Studio' and the 'Process Console') $DBMS_SYS
    ;-  is defined with a separate assignment, so that transactions that save 'Model Data' can be separated
    ;-  from transactions that save 'Preferences'.
    $DBMS        SOL:nmpipe Uniface_94_Development_Solid_Database:|uniface|nine
    $DBMS_SYS    SOL:nmpipe Uniface_94_Development_Solid_Database:|uniface|nine

    $SYS    $DBMS_SYS
    $UUU    $DBMS
    $DEF    $DBMS
    $IDF    $DBMS
    ;- $WFM, used for the Uniface Flow instance data, must use the same path as $IDF:
    $WFM    $IDF

    **********************************************************************************************************************

    on the DSP:

    go to the structure tree and select the component

    - RIGHT CLICK should show you options to add objects

    - same possible with the buttons at the bottom of the window.

    I think they have some document or tutorial in the helpfile explaining how to create a DSP.

    SUccess, Uli


    Author: ulrich-merkel (ulrichmerkel@web.de)
  10. Hi Uli,

    I have not tried the solution with Solid due to time. So I'm still with SEQ.

    I created an USP with deux entities for data and one entity for the command button. It's ok to compile.

    Just one problem when I want to test :

    http://localhost:8080/uniface/wrd/run/ARTART_BRS30        ---> ARTART_BSR30 is my USP component

    I use Mozilla and I get 300 URD Error Page :: MiddleWare : UV8 :: Error# : -25

    I think I create a signature for this component.

     

    I've configured everything well ?

     

    Thanks for the response.

     

    Jérôme

     

    PS : if not me who just Uniface 7, the new version has greatly evolved. XML, Web, C/S... as opportunities. It remains to make the tool very intuitive for beginners and do a good learning book. Also do not miss the turn of mobility...


    Author: Bignon (bignonj@gmail.com)
  11. Hi Jérôme

    That message means that your urouter is not running corectly.

    Goto : Administrative Tools --> services

    and find the uniface ones.  All these should be started... for your problem it is the 'Uniface 94 Development URouter'

    (btw: you are going to spend the rest of your life in these services start and stopping stuff.. so be nice to them)

     

    Just to make sure try this and make sure you get a page with some data on it... this will check your Web Request Dispatcher is running

    http://localhost:8080/uniface/testwrd/run/ARTART_BRS30

    Result something like :

    WRD version: 4.3
    API needed: 2.2
    Build name: O310
    Date: 2010-02-04

    ...

    WRDServlet activated

    ..

    ...

     

     

    If it is running but you still get the problem i suggest you read following.  The problem would be that you are using a work computer with users/groups set up and so additional privilage acess is necessary... it will only take a few minutes but took me months to figure out.

    http://hosted.byjones.net/turf/viewtopic.php?f=2&t=1236

    Basically what I did was to :-

     1) I created a new user on my computer

     2) I then gave it batch privileges..

     3) Then changed file web.xml and replaced userver|userver with the new user and password
        ...\uniface\webapps\uniface\WEB-INF

     

    The others reasons would be that you have done some advanced playing around with the urouter.asn and web.xml but as it is out the box this is probably not the reason.

     

    osie


    Author: osie_osie (osieman@gmail.com)
  12. hi Jérôme,

    When, I installed the Uniface 9.4 trial version. At the time of testing 1st DSP, I was facing following error.
    300 URD_MW_ERROR
    Middleware : UV8
    Error#     : Failure in the connection to the UNIFACE Application Server
    Error Text : Cannot connect to the UNIFACE process on the remote address/port. The system returned: "Bad connection parameters".
    After the analysis, I came to know that Uniface has not created the user “userver” at the time of installation. May be because windows doesn’t create normal password like userver, it requires mixed password (not sure)
    Step resolves this error:
    1.     Go to control panel -> Administrative tool -> Computer management -> Local users and groups
    -> Users -> create new user -> “userver “
    2.     Add this user to “Uniface server users” group.
    3.     Then changed file web.xml and replaced userver|<password>    ...\uniface\webapps\uniface\WEB-INF
     
    If you are facing an error “300 URD Error Page:: MiddleWare : UV8 :: Error# : -25”. It means user or password is wrong.

     

    Regards,

    Parikshit


    Author: pari_shelar (pari_shelar@yahoo.com)