Timeout using Sql Server 2008

Author: parcaya@compuamerica.com.ve (parcaya)

Hi, we are having problems executing a form in Uniface 9.5.1 trying to retrieve data from a table using non-index fields. Sql Server 2008 always returns a timeout error:

I/O function: S, mode: 0, on file/table: XTABLE index: 1 >=
HYT00 [Microsoft][SQL Server Native Client 10.0]Query timeout expired
Somebody knows how to fix this. In Sql Server 2000 this did not happened.
Thanks

5 Comments

  1. Hello,

    I have also shifted from SQL2005 to SQL2008 and I had similar timeout problems.

    Can you try these settings:

     

    USYS$MSS_PARAMS = recsize=4000

     

    Cheers

    Johnny


    Author: johnny_ujoodha (johnny@amcmsia.com)
  2. UnifAce use other cusor types then MS-SQL :-(

    Whenever you enter a SELECT in the (Microsoft)-SQL-Editor,  a non-update cursor-type is choosen by Microsoft.

    UnifAce instead use allway an updatable cusror-type.

    So the SQL-Editor can return the result-set faster then UnifAce, which runs (on big tables) into a timeout.

     

    Ingo


    Author: istiller (i2stiller@gmx.de)
  3. Hi,

    We have had luck with this MSS_PARAMS setting -

    [DRIVER_SETTINGS]
    MSS U4.0
    USYS$MSS_PARAMS blah, blah, blah, maxlockwait:infinite
     

    I was assuming you were also moving up to MSS 4.0 with your SQL migration.

    Doug


    Author: DKemp (doug.kemp@noris.org)
  4. Hmmm, is there a page somewhere which details the difference between MSS3.0 and MSS4.0?


    Author: Iain Sharp (i.sharp@pcisystems.co.uk)
  5. Hi,

    Another MS-SQL Connector option to try combining is

    USYS$MSS_PARAMS step size = 100, procs=off, checks=off, identifiers=quoted, mapping:2, locktime:infinite, lock isolation:ru, hs:on, stmtcache:off, maxlockwait:infinite

    Doug


    Author: DKemp (doug.kemp@noris.org)