SOLVED: update a $valrep on a DSP

Author: lammersma@hotmail.com (lammersma)

Hi all,   I need a bit of help with a problem I have.   On a DSP I want to update the $valrep of a dropdown. In the debugger I can see the $valrep gets a new value, but in the browser the old values is shown.

  1. On the first activate: $valrep of the dropdown is filled with an associative list. 
  2. When I push a button in the detail trigger a new associative list is build
  3. the dropdown receives the new list as an $valrep
  4. as mentioned the debugger shows the correct $valrep, but in the browser the old list is shown...

In the SetState contains the default coding. I tried to put the webdefinitions statement in the update part of the selectcase in that trigger. But that does not change anything in the client behavoir.   Kind regard,   Peter

2 Comments

  1. Hello Peter, for performance reason, $valrep list is send only once, at the initialization of the DSP, to the browser. if you need to change the list at runtime, use $fieldvalrep instead.   Hope this help, Philippe


    Author: Philippe (philippe.grangeray@agfa.com)
  2. Hi Philippe, Thanks for your answer. You solved my problem. Kind regards, Peter


    Author: lammersma (lammersma@hotmail.com)