Problem importing WSDL

Author: sven.hedqvist@gmail.com (Sven_Hedqvist)

Hello all I am conducting a test to see how call out to web service works and I immediately run into problems. A simple test with /sti /mwr=ws http://www.webservicex.com/globalweather.asmx?WSDL generates no signature, and the log says: Unable to locate: UGENWSO *** The application has tried to dynamically perform this 3GL function but could not find it. *** Check if you have an entry for this function in the [USER_3GL] section of your assignment file. What do I need to do? An entry into [USER_3GL] of asn-file? We do not have such a section today, and as far as importing WSDL nothing in Ulibrary or other sources says anything about this UGENWSO. Anyone know what I should do? Best regards /Sven Hedqvist

9 Comments

  1. Hello Sven,

    You have to enable the SOAP U2.0 driver by adding the appropriate entry to the [DRIVER_SETTINGS] of your ASN file. And if you have to use a proxy to access the Internet from your system then you also have to add the specific connector option. For example

    [DRIVER_SETTINGS]
    SOP=U2.0
    usys$sop_params = proxy=myproxy.com:1234

    For details see the corresponding topics in the Uniface Library:

    • Integrating With Other Technologies > Web Services > Call-Out From Uniface to a Web Service > SOAP Connector
    • Integrating With Other Technologies > Web Services > Call-Out From Uniface to a Web Service > SOAP Connector Options

    Hope this helps.

    Kind regards,
    Daniel


    Author: diseli (daniel.iseli@uniface.com)
  2. Thanks! I will give it a try


    Author: Sven_Hedqvist (sven.hedqvist@gmail.com)
  3. Well that made me go one step further, but not much :-)

    I provided the following into the asn:
    [driver_settings]
    SOP=U2.0

    .. wich made the previous error go away, but now the log says:
    INFO: Import WSDL File Utility for Web Services Call-Out U2.0
    INFO: WSDL File:http://www.webservicex.com/globalweather.asmx?WSDL
    ERROR: UINSTNEW: URMWI_API service is missing, check that urmwiapi.svc is present in your installation

    As far as I can tell, the urmwiapi.svc is present in C:\Program Files\Compuware\Uniface 9.4.01\common\components though..


    Author: Sven_Hedqvist (sven.hedqvist@gmail.com)
  4. Do you have the correct settings for the following in your idf asn?

    usys:idf.aps
    usys:uu*.frm
    usys:ur*.svc - Particularly this one.
    usys:uu*.svc
    usys:*.xml


    Author: Iain Sharp (i.sharp@pcisystems.co.uk)
  5. Hmmm.. I think so. I am going to consult our CM on this.


    Author: Sven_Hedqvist (sven.hedqvist@gmail.com)
  6. http://uniface.communityzero.com/uniface?go=2358199

    Regards RogerW.


    Author: rogerw (roger.wallin@abilita.fi)
  7. FYI, I tried this very same things a few months ago - I had no problem. My settings are as per the other replies to your case and I am on 9.3.02.

     

    Tatiana


    Author: tandron (tatiana@ca.ibm.com)
  8. Did you install SOAP Tool Kit?


    Author: MartinsM (marcelo.aamartins@gmail.com)
  9. I got it working now. We had to explicitly point to C:\Program Files\Compuware\Uniface 9.4.01\uniface\usys\uidf.uar for uniface to find the signature of urmwiapi


    Author: Sven_Hedqvist (sven.hedqvist@gmail.com)