Permission Control in IDF

Author: knut.dybendahl@gmail.com (Knut)

So, I decided to turn on the Permission Control under System Preferences. I had a look at the various options that opened up - then I went back and turned it off again - all within the same session in IDF. I repeat, I did not leave IDF whilst turning on / turning off. Now, when I attempt to get into the local development env on my laptop at home - I get the username / password box... Where in the repository is this stored? I've cleaned out UOBJ - there's nothing in UMEMBER - all tables in SYSENV are empty - so what's missing? Any ideas anyone apart from restore backup / create a new repository? Knut

3 Comments

  1. Just my few cents: UUSRPRF - USYSPRF? (Are you sure they are empty...mine are NEVER empty!) I bet on USYSPRF... As alternatives: .ini file? registry? Good luck!


    Author: gianni (gianni.sandigliano@unifacesolutions.com)
  2. Hi Knut, This is the ultimate test for a Uniface user to check if he has the right stuff. Wink Just kidding... Smile This should do the trick: you have to delete all records from the following tables in order to "disable" the Permission system again: * UMEMBER * USUBJ and OUSUBJ * UPERMIT * USYSPRF and OUSYSPRF * UUSRPRF and OUUSRPRF * UOBJ and OUOBJ Last but not least delete the UOBJ.DOL if it exists and create a new one if necessary. After you've done this it should be possible again to get the Uniface Development Environment working again. In case the logon screen still appears when starting the IDF then just close it by pressing cancel. I hope this helps. Kind regards, Daniel


    Author: diseli (daniel.iseli@uniface.com)
  3. Hi Daniel and Gianni, Devy (UF Support) came to the rescue; For the sake of security - I won't post the whole solution... update usysprf .... (1 row) delete from uobj where .... (1 row) Hey presto, we're all good... Kudos to Devy! Regards, Knut


    Author: Knut (knut.dybendahl@gmail.com)