Move from 8.2.03 to 9.4

Author: rmeaille@medinfo.fr (foster06)

Hi all,

I need to move my application from Uniface 8.2.03 to 9.4 because I need to use unicode.

I moved first from 8.2.03 to 8.4.06. I made the necessary modifications.

Then I moved from 8.4.06 to 9.4.c1.

Now I need to continue using DOL and URR file.

After /all to compile all objects, and /urr and /dol, the files are created but in udesc.urr I haven't any signatures, and in usys.dol, I just have the uniface messages.

I don't understand what I need to do to have good URR and DOL files, like in uniface 8.

Thanks for your help.

Robert

6 Comments

  1. What is in you asn files?

    My guess is Uniface has made the correct DOL and URR files, but not in the location that you are looking for them now.


    Author: Theo Neeskens (tneeskens@itblockz.nl)
  2. Thanks thenees for your answer.

    I already control that DOL and URR files is created in the good place.

    First lines of My asn is :

    [SETTINGS]
    ;$language=F

    ;$enhanced_edit=all

    $VARIATION                  HEMATOS
    $SEARCH_RESOURCES           resources_last
    $RESOURCES_OUTPUT           C:\Hematos\V3.0\Version

    $PUTMESS_LOGFILE            idf.log

    [RESOURCES]
    C:\Hematos\V3.0\Version

    [FILES]
    usys:idf.aps            usys:..\components\idf.aps
    usys:uu*.frm            usys:..\components\uu*.frm
    usys:ur*.svc            usys:..\components\ur*.svc
    usys:uu*.svc            usys:..\components\uu*.svc
    usys:*.xml              usys:..\misc\*.xml

    usys:udesc.urr          C:\Hematos\V3.0\dolurr\udesc.urr
    usys:uobj.dol           C:\Hematos\V3.0\dolurr\uobj.dol

    *.apslst = lst\*.apslst
    *.cptlst = lst\*.cptlst
    *.menlst = lst\*.menlst
    *.prclst = lst\*.prclst


    ;*.aps                   C:\Hematos\V3.Beta-local\application\*.aps
    ;*.frm                   C:\Hematos\V3.Beta-local\application\*.frm
    ;*.svc                   C:\Hematos\V3.Beta-local\application\*.svc
    ;*.rpt                   C:\Hematos\V3.Beta-local\application\*.rpt
                      
     

    Any idea ?

    Thx

     


    Author: foster06 (rmeaille@medinfo.fr)
  3. By using *RESOURCES*, you tell Uniface to use the new deployment model (no URR, no DOL, but compiled objects written to your $RESOURCES_OUTPUT path).

    Remove any reference to *RESOURCES* in your ASN file and you should get your URR and DOL back.


    Author: cwfr-lizac (laurent.izac@compuware.com)
  4. Thanks thenees for your answer.

    I already control that DOL and URR files is created in the good place.

    First lines of My asn is :

    [SETTINGS]
    ;$language=F

    ;$enhanced_edit=all

    $VARIATION                  HEMATOS
    $SEARCH_RESOURCES           resources_last
    $RESOURCES_OUTPUT           C:\Hematos\V3.0\Version

    $PUTMESS_LOGFILE            idf.log

    [RESOURCES]
    C:\Hematos\V3.0\Version

    [FILES]
    usys:idf.aps            usys:..\components\idf.aps
    usys:uu*.frm            usys:..\components\uu*.frm
    usys:ur*.svc            usys:..\components\ur*.svc
    usys:uu*.svc            usys:..\components\uu*.svc
    usys:*.xml              usys:..\misc\*.xml

    usys:udesc.urr          C:\Hematos\V3.0\dolurr\udesc.urr
    usys:uobj.dol           C:\Hematos\V3.0\dolurr\uobj.dol

    *.apslst = lst\*.apslst
    *.cptlst = lst\*.cptlst
    *.menlst = lst\*.menlst
    *.prclst = lst\*.prclst


    ;*.aps                   C:\Hematos\V3.Beta-local\application\*.aps
    ;*.frm                   C:\Hematos\V3.Beta-local\application\*.frm
    ;*.svc                   C:\Hematos\V3.Beta-local\application\*.svc
    ;*.rpt                   C:\Hematos\V3.Beta-local\application\*.rpt
                      
     

    Any idea ?

    Thx

     


    Author: foster06 (rmeaille@medinfo.fr)
  5. Thanks Laurent,

    I try and confrm

     


    Author: foster06 (rmeaille@medinfo.fr)
  6. Thanks for all,

    Now DOL and URR are well created.

    Robert

     


    Author: foster06 (rmeaille@medinfo.fr)