Importing WSDL

Author: roger.wallin@abilita.fi (rogerw)

Uniface: 9.4.01.02 R103
Hi,

I'm trying to import a WSDL definition for a web-service getting this error:

INFO: Import WSDL File Utility for Web Services Call-Out U2.0
INFO:   WSDL File:http://www.....
ERROR: UINSTNEW: URMWI_API service is missing, check that urmwiapi.svc is present in your installation
2010-10-18 16:31:29.13 - Uniface session stopped

I've also tried putting urmwiapi.svc in the usys-directory, and changing the asn-file in several ways.

Default Uniface9:
[FILES]
usys:idf.aps            usysuniface:components\idf.aps
usys:uu*.frm            usysuniface:components\uu*.frm
usys:uu*.svc            usysuniface:components\uu*.svc
common:uu*.frm          usys:..\components\uu*.frm
common:uu*.svc          usys:..\components\uu*.svc
common:ur*.svc          usys:..\components\ur*.svc 

Has anyone else had similar problems?

Regards RogerW.
 

5 Comments

  1. Hi RogerW,

    Do you have the /adm switch set on your IDF shortcut? I've seen similar missing component errors when that hasn't been setup.

    James


    Author: James Rodger (james.r.rodger@gmail.com)
  2. Hi,

    I tried to put  "/adm=mydrive:\programs\uniface94\uniface\adm" (where idf.asn is located) in front of the /asn switch but that didn't help. I hope it isn't a license problem?

    Regards RogerW.
     


    Author: rogerw (roger.wallin@abilita.fi)
  3. Hi,

    Maybe this helps in finding out what is wrong.

    Make new Form with just this in the execute trigger

    debug

    activate "urmwiapi"

     

    Test the Form, in the debugger: View -> Setting switch on Operating system calls and Component descriptors

    Step to the activate. When you get a $status 0 the service could be found, -50 is not found.

    In the message frame you can see where Uniface tried to find the service.


    Author: Theo Neeskens (tneeskens@itblockz.nl)
  4. Thanks Theo,

    you pointed me in the right direction.
    The actual problem seemed to be the "easy deployment" settings.
    Temporary removing the rows below solved it !?!?

    $search_resources  =    Resources_Last
    $RESOURCES_OUTPUT  =    g:\produktion\myapp

    Regards RogerW.


    Author: rogerw (roger.wallin@abilita.fi)
  5. Pointing to

    [RESOURCES]
    C:\Program Files\Compuware\Uniface 9.4.01\uniface\usys\uidf.uar

    seems to solve it without having to remove the
    $RESOURCES_OUTPUT = g:\produktion\myapp

    See also 

    Problem importing WSDL

    Regards RogerW


    Author: rogerw (roger.wallin@abilita.fi)