Error -21 on Localhost

Author: amonserrat@sfa-durango.gob.mx (jr_naxera)

Hello everybody:
We have experienced a problem while trying to test a USP converted from a Form, in the localhost. The browser (Mozilla Firefox) displays a Error 300, about not being able to reach URouter. The log shows this is due to an Error -21, which refers to not being able to perform a login in the network. However,as stated, we are testing it on the local machine. Has anybody experienced something similar? Or can you provide us with any insights as to what could be the problem?

Thanks and happy holidays

8 Comments

  1. Hi,

    if you run web-applications (USP, DSP), the requests are sent via the browser to an instance of uRouter
    which in turn opens a uniface-environment to handle the request.

    So even for local machines, you have to install a proper uniface server (now combined applicationserver, polyserver, ...).

    Success, Uli.

    P.S: if you have access to the 9.4.beta program, they provide you with a complete installation (Apatche, ...).


    Author: ulrich-merkel (ulrichmerkel@web.de)
  2. Greetings, Uli, and thanks for the answer.
    Yes, we use Uniface 9.3 with the default application server, Apache Tomcat. We have launched it, along with checking that the service of Urouter is up and running. Since the test machine is behind a proxy in the LAN,  I have configured the browser to use the local IP for requests made to localhost, as that was causing us some trouble. This last error, however, is quite cryptic, as it refers to login into a network it shouldn't have to go to fetch the page.


    Author: jr_naxera (amonserrat@sfa-durango.gob.mx)
  3. Don't agree that you need no network login for localhost:

    As far as uniface is concerned, even "localhost" is a network adress
    and if you want to run a process, you need valid logon information for your PC
    in your asn file.

    Success, Uli


    Author: ulrich-merkel (ulrichmerkel@web.de)
  4. Greetings

     Well, to fetch he page, as far as we have dilucidated, Tomcat uses the default WRD settings as established in the web.xml to fetch the page from URouter. However, URouter is not responding to this request. Since we are using every asn as it was created by the installation, we are can't figure what causes URouter to refuse the default login information of  "userver" as username and password.


    Author: jr_naxera (amonserrat@sfa-durango.gob.mx)
  5. Hello,

    I have met this issue in 9.4beta, on windows, depending how the urouter service was registered.

    ie: 

    • by registering the service by:

    urouter.exe /inst tcp:localhost+13000

          it was impossible to reach the service outside of the server. 

    • by registering the service by:

           urouter.exe /inst tcp:192.168.0.1+13000

           it was impossible to reach the service inside of the server by localhost.

     This issue doesn’t seem to belong in 9.4CR1.

     Philippe

     


    Author: Philippe (philippe.grangeray@agfa.com)
  6. Hi Philippe,

    the latter depends on the specification of "localhost"
    in your C:\WINNT\system32\drivers\etc\hosts file

    # Copyright (c) 1993-1999 Microsoft Corp.
    #
    #      102.54.94.97     rhino.acme.com          # Quellserver
    #       38.25.63.10     x.acme.com              # x-Clienthost

    127.0.0.1       localhost

    Success, Uli


    Author: ulrich-merkel (ulrichmerkel@web.de)
  7. Not sure if this has been sold or not but here is a solution to try...

    I had the same problem due to having a computer with groups/users set up.... the way I resolved it was to create a new user on my machine with the correct group privilalges and then used this user to connect to urouter.

     

    Thanks

    osie

     

    Here  is the resolve:-

    I saw a youtube vid (http://www.youtube.com/watch?v=FVPOlQPu3Do there are 3 parts to it)
    I created a new user on my computer as is done in the video.

    I then gave it batch privileges.. and every other privilege under the sun
    see the turf viewtopic.php?f=11&t=104&p=262#p262

    Then changed file web.xml and replaced userver|userver with the new user and password
    ...\uniface\webapps\uniface\WEB-INF


    Author: osie_osie (osieman@gmail.com)
  8. ... definitely a USER RESTRICTION problem- as said before by others: you'll need to provide the SERVICE and the USER RUNNING THE SERVICE to have rights to do, whatever it should do:

    Look at you web.xml:

    <init-param>

      <param-name>MIDDLEWARE</param-name>

      <param-value>UV8:localhost+13006|USERNAME\MACHINE|PWD|wasv</param-value>

    </init-param>

     

    Place the correct user here. He needs to have those mentioned rights which en detail are  LOG ON AS BATCH JOB and LOG ON AS SERVICE or you wont go anywhere ;)

    If you are working withing a WINDOWS DOMAIN, consider to make a profile, which is knows in the domain:

    <init-param>

      <param-name>MIDDLEWARE</param-name>

      <param-value>UV8:localhost+13006|USERNAME@DOMAIN|PWD|wasv</param-value>

    </init-param>

     

    Good luck to you,

    -GHAN-


    Author: -GHAN- (hansen@ahp-gmbh.de)