Debugging DSP

Author: claudio.palladini@cortislentini.it (Claudio)

Hello, sometimes happens that the debugger process starts, but navigating the URL of the DSP, Uniface does not "hook" the debugger. So I have to restart the Urouter and Tomcat services and IDF, to make it work again. From Urouter.asn:

debug = "C:\Program Files (x86)\Uniface\Uniface 9.7.01\common\bin\userver.exe" /max=1 /dir="C:\Program Files (x86)\Uniface\project" /adm="C:\Program Files (x86)\Uniface\Uniface 9.7.01\uniface\adm" /deb=localhost+13002:wait /asn=wasv.asn Hints on what I've wrong?Confused Thanks all Claudio --- EDIT --- Release 9.7.03 Update G302 1012_1 Platform W2 OS: Windows 2008 R2 Standard SP1

4 Comments

  1. Ciao Claudio, in a standard installation the initial connection between UServer process and Server Debug process is succeding when: A) the port configured to debug is available     AND B) the Server Debug is started     AND C) the URL for the DSP to be tested is including the correct (debug) servlet reference: http://server+port/uniface/debug/DSPname Are you sure all those conditions are met? In a multiuser environment more UST acting as "Server Debug" could be configured in urouter.asn using different ports. Gianni


    Author: gianni (gianni.sandigliano@unifacesolutions.com)
  2. Hi Claudio, You state 'Release 9.7.03', but in your debug line I see \Uniface 9.7.01\ Any chance of: - two Uniface installations biting each other here? - part of Uniface installation copied from somewhere instead of run through the installer? - wrong reference of sub-directory in the activation line in Urouter.asn? - etc. From you debug line I conclude that you have chosen to have your default project directory also in C:\Program Files ( /dir=”C:\Program Files (x86)\Uniface\project” ). Although this was common practice in older Uniface versions, with the introduction of Windows 8 and 10 (and the Windows Server equivalents), C:\Program Files has become a 'protected' directory. Having your default project directory in C:\Program Files is not a preferable option for a project directory any more. Please see Daniel Iseli's excellent explanation in this forum topic. Cheers, Arjen


    Author: Arjen van Vliet (arjen.van.vliet@uniface.com)
  3. What is the timeout on your wasv setting in urouter.asn?  If you have run a 'remote' debugger against the process, and closed the debugger, the process is not terminated (unlike doing a debug from uniface.exe), starting another remote debugger but using the same userver process will not 'hook' the two together. You either have to leave the debugger running or stop the userver.exe and therofore start a new one. 


    Author: Iain Sharp (i.sharp@pcisystems.co.uk)
  4. Iain Sharp said What is the timeout on your wasv setting in urouter.asn?  If you have run a 'remote' debugger against the process, and closed the debugger, the process is not terminated (unlike doing a debug from uniface.exe), starting another remote debugger but using the same userver process will not 'hook' the two together. You either have to leave the debugger running or stop the userver.exe and therofore start a new one.   

    Thanks everyone for the advice, but I think Iain has hit the issue. There is the possibility to start the debugger contextually with the launch of the DSP, as in other development environments? Thanks Claudio


    Author: Claudio (claudio.palladini@cortislentini.it)