Uniface 8.4.0.2 and Oracle 10g

Author: michael.hoogenboom@telecom.co.nz (hoogmike)

We have a Uniface 8.4.0.2 application and have upgraded our database to Oracle 10g. We now have a problem when we try to run the application;

Error:

Unable to open uora44; error ld.so.1: uniface: fatal: uora44.so: open failed: No such file or directory.

 

the libuora44.so does exist at the following location:

/appl/uni/usys/8402/lib/libuora44.so

 

 

Wondering if this has something to do with the ORA driver version. The version set in the ASN file is:

[DRIVER_SETTINGS]

ORA     U4.4

 

Does Uniface require a different ORA driver to work with Oracle 10g?

Thanks.

 

 

5 Comments

  1. Hello,

    I think you need driver U6.0, so the file you need is libuora60.so

    But I don't think Oracle 10 is supported with Uniface 8.4.02

    If you can migrate to 8.4.06 or 9.3, the library is provided.  It is the safest way.

     

    But if migration is not an option for you, you can try download latest service pack or patch for your platform

    at this URL ftp://ftp.compuware.com/pub/uniface/servicepacks/8405/hph/ (or similar following your platform),

    and then extract only the file libuora60.so (this file is the driver for Oracle 10).

    It should/could work with 8.4.02, but it's surely NOT supported !!!

    I don't recommend this for production application, but for testing purposes, you can try it.

    Regards.


    Author: BenHen (benoit.henry@hotmail.com)
  2. Thanks, we tried specifying the U6.0 driver in the ASN but get the same error message as before, this time it saying it cannot find uora60.

    libuora60.so is in the same directory as libuora44.so


    Author: hoogmike (michael.hoogenboom@telecom.co.nz)
  3. Hi,

    I've had that error when the uora dll can be found, but another dll it needs can't be found. Could you check you have the appropriate Oracle 10 client libraries installed correctly? I'm afraid I don't know exactly what gets used, but this has fixed it for me in the past.

    edit: Oops, that's on Windows, but maybe worth a try anyway,


    Author: James Rodger (james.r.rodger@gmail.com)
  4. Hi,

    you have to differ between the version numbers of Oracle server and Oracle client. For an uniface client application gaining direct access to the database (without using an userver) the version of the client software is important. Meaning you can access a 10gv2 database using a 8.1.7 client installation.

    From my point of view that is the only way you could choose if you don´t want to upgrade you uniface environment. The compatibility matrix for Uniface 8.4 (http://frontline.compuware.com/products/uf/tech/PAM8406_june_2009.pdf) tells us two things:

    1. Oracle 10gR2 is supported from versions not less than 8.4.0.3 D305
    2. the correct driver setting is U6.2

    Try it out - it will work.

    Regards

    Edit: Nevertheless you should consider that Oracle 8.1.7 isn´t supported anymore and upgrading Uniface 8.4 to 8.4.0.6 isn´t that critical.


    Author: Marvel (thomas.hucke@spb.de)
  5. i think than uniface use uora6.2 for oracle 10 g.

    we have oracle 10g and uniface 842 and i use ora=u6.2


    Author: bobdup (robert.duplessis@compuware.com)