Slow to authenticate user to instantiate userver

Author: marco.aquino@dedalus.eu (Marco)

Hi,

I have a java application that invoke a Uniface webservice via urouter.

I notate that it is very slow to execute the call.

On the urouter log I saw that it takes 2 second on the follow bold lines

  0:48.261.58 t=3676: From Client:chn=305;len=114: CLTCON;
  0:48.261.60 t=3676:     clt=(hst=192.168.128.105,CSRVAPPNFS;pid=0;tid=0;sid=0;usr=nobody;ust=)
  0:48.261.62 t=3676:     log=(hst=TCP:CSRVAPPNFS+14000;usr=intranet\nfsuser;ust=ws)
  0:48.261.63 t=3676: reguser: nid=192.168.128.105, node=CSRVAPPNFS, pid=0, ust=
  0:50.309.81 t=3676: To Client:chn=305;len=2: CONANS; continue:

I think that relates to user authentication.

On uniface servlet (web.xml), the urouter is call with a network user with this line:

      <servlet id="Servlet_Standard">
         <servlet-name>srd</servlet-name>
         <servlet-class>com.compuware.uniface.urd.SRDServlet</servlet-class>
         <init-param id="InitParam_Standard">
            <param-name>MIDDLEWARE</param-name>
            <param-value>UV8:csrvappnfs+13000|domain\user|password|ws</param-value>
         </init-param>
         <init-param id="InitParam_asvtimeout">
            <param-name>ASVTIMEOUT</param-name>
            <param-value>500</param-value>
         </init-param>
      </servlet>
 

I tried with a local user but the time is the same.

 

Any idea??

Marco

9 Comments

  1. Hi Marco, We currently have a support case with another customer who reports exactly the same. We found out that it is the Windows function LogonUser() that takes exactly two seconds to execute. It's not clear why, it happens only on a specific machine. They are working with Microsoft to resolve this (because we at CPWR can not reproduce the issue). I guess this may be your problem too. Do remind me to post back here when a solution is found for it.


    Author: None (None)
  2. Thanks, I'm waiting for the solution. In the meantime will try solutions. Marco


    Author: Marco (marco.aquino@dedalus.eu)
  3. What anti-virus software and OS are you using?

    Duncan


    Author: None (None)
  4. Windows 2003 Server R2
    Symantec Endpoint

    Marco


    Author: Marco (marco.aquino@dedalus.eu)
  5. The other customer I mentioned have found that it was Symantec Endpoint causing the delay. Though I'm waiting more details, it seems like re-installing that software fixed the issue. Since you are using it too, you may want to try the same. Do let me know if that fixes it for you. Chris


    Author: None (None)
  6. Thanks I will try this.

    Marco


    Author: Marco (marco.aquino@dedalus.eu)
  7. Marco, Have you tried re-installing Symantec Endpoint and did it fix the problem ? Chris


    Author: None (None)
  8. No, I informed the customer and I'm waiting to reinstall the program. The servers are dependent on them.

    Marco


    Author: Marco (marco.aquino@dedalus.eu)
  9. Hi,
    after uninstall and install Symantec EndPoint the time to authenticate is fast.
    Thank you

    Marco


    Author: Marco (marco.aquino@dedalus.eu)